Welcome to OpenFX Online Help

Ajuda do módulo Animador


How to Use This Function Reference

Como usar esse manual de referência rápida

Esse manual tem como objetico dar uma referência do trabalho no OFX a novatos e experientes usuários. Para encontrar a função procurada, note o menu onde algumas opções aparecem, e procure nos sub-menus o conteúdo.

Todas as funções são listadas em ordem do menu, da esquerda para a direita e do alto para baixo. O layout geral, ícones e ferramentas são listados no início da seção de cada módulo, depois dos menus.


Terms used in the Animator

Termos usados no Animador

Cursor3D - Um programa bidimensional possui um único cursor, mas quando trabalhamos no espaço 3D precisamos de um cursor adicional que possa trabalhar nas três dimensões espaciais. Ele pode ser colocado em qualquer lugar do espaço 3D com o ponteiro do mouse.

Ator - Um ator é o termo usado para cada elemento na animação. Um ator possui um Avatar (personificação), o avatar é mutável na animação o ator é constante. Há 12 tipes de atores. O mais importante é o tipo modelo. Uma ator modelo usa um avatar que é um modelo criado no Designer. Para entender isso imagine uma aeronave voando sobre uma cidade seguindo um caminho pré-definido, a aeronave é o ator modelo usando uma avatar de um caça F15, imagine que na verdade deveria ser um F117 na animação, para acertar basta apenas trocar o avatar do ator modelo aeronave por uma avatar de um modelo de F117. Modelos são gravados com a extensão de arquivo .MFX.

Trilha do ator- É o caminho que o ator seguirá durante a animação. Uma trilha somente será visível se houver duas linhas do tempo de movimento que sejam contíguas.

Janela ativa - É a vista que está atualmente em foco. Ela é iluminada por um contorno amarelo. Pressione Tab para caminhar pelas vistas, clique com o mouse numa vista para torna-lá ativa.

Ponto pivô - Cada modelo tem um ponto usado no animador para manipular o modelo. Por exemplo se um modelo for uma aeronve seguindo um caminho o ponto do modelo que exatamente segue o caminho é o ponto pivô.

Linha do Tempo - Para direcionar a atividade de um ator na animação é requerido o uso de 4 linhas do tempo, avatar, posição, rotação e tamanho. Uma linha do tempo expande um número de quadros e possui um quadro-chave associado a eles. O quadro-chave é o quadro onde a ação do ator é exatamente especificada, enquanto que nos outros quadros intermediários o programa calcula sozinho baseado na interpolação dos valores.

O quadro-chave sempre será o último quadro na linha do tempo. Uma linha do tempo é o intervalo de quadros onde o ator efetua as ações determinadas pelo quadro-chave.

Linha do tempo expandida - É o quadro atual se ele na linha do tempo é menor igual ao quadro atual e se o último quadro na linha do tempo é maior ou igual ao quadro atual.

Avatar - Para ser visível na animação um Ator precisa possuir um avatar. O tipo de ator dita que sorte de avatar ele pode possuir, mas atores podem mudar de avatar durante a animação.

Quadro atual - É o quadro na animação que é exibido na vista e onde qualquer mudança pode ser feita.

Curva - Um conjunto de vértices concectados por arestas sem formar nenhuma face. Curvas podem ser abertas ou fechadas.

Aresta - Um seguimento de reta conectando dois vértices.

Face - Uma superfície triangular definida por 3 arestas unidas exatamente por 3 vértices .

Ponto perseguidor - Uma localização (Especificada no Designer) no modelo onde outro objetos podem seguir.

Quadro - Igual a convenção cinematográfica de quadros para cinema e animação. Pode ter imagens em seguência na proporção por exemplo de 24 quadros por segundo. Cada quadro é composto de uma imagem.

Matiz Plástico - Um algorítimo de renderização que sombrea o modelo misturando e desfocando superfícies adjacentes. É usado pela vista OpenGL.

Mapeamento imagem - Um mapeamento imagem é um arquivo GIF ou TGA que será usado para "pintar" faces do modelo adicionando decalques detalhados na superfície.

Indicado - Para escolher um particular vértice, aresta, face, ou objeto para ser afetado por uma operação sem seleciona-lo coloque o Cursor3D sobre ou próximo a ele (entre um ou dois "pixels") para ser indicado. se mais de um elemento está indicado então o mais próximo do cursor3D será usado.

Quadro-chave - Um quadro chave é o quadro onde algumas informações são especificadas sobre a atividade do ator. O conceito é igual ao dos desenhos animados onde o desenhista mestre determina as partes importantes da animação e os desenhistas de produção fazem os quadros intermediários, aqui no caso feito pelo programa.

Q-chave - É a barra inferior do Animador onde é exibida as linhas do tempo (avatar, posição, rotação e tamanho) do ator atual. Onde vc pode inserir e modificar os quadros-chaves da animação.

Modelo - É unidade principal da estrutura. Um modelo é feito por faces e cada face é determinada por três arestas. O tamanho, posição e orientação da face é determinada pelos vértices que a definem.

Chaves de modificadores - O Shift, Ctrl e Alt são usados para modificar a ação das ferramentas do Designer. Se um ou outro é usado então a ferramenta é modificada apropriadamente.

Morfose - Proporciona que um modelo se transforme em outro.

Nó - Um nó é um ponto em um caminho ou robô que pode ser manipulado. E representado por um pequeno quadrado.

Origem - A origem padrão são as coordenadas de valores (0, 0, 0).

Caminho - Uma Curva que é usada no Animador como caminho para os atores seguirem (.PTH). E pode ser usado no Designer para definir uma extrusão.

Matiz esmalte - Um algorítimo de renderização que sombrea um modelo suavizando e descreve superfícies, texturas e propriedades de reflexão e pode simular espelhos. O Render usa essa matiz como padrão se o raytrace não estiver ativo.

Suavizar - Esse é um procedimento que ajuda a remover a aparência facetada da superfície de um modelo.

RayTrace - Um complexo sistema de renderização capaz de criar efeitos espelho, transparências, sombras, e refrações.

Status da Seleção - Cada vértice no modelo pode ter um desses estados: Selecionado, Deselecionado, Oculto. Selecionado vértices são manipulados pelas ferramentas e ações. Deselecionado Vértices não são afetados pelas ferramentas ou ações. Oculto vértices não são exibidos e não são afetados.

Textura - Uma textura é um algorítimo que pode adicionar finos detalhes a superfície do modelo. Exemplos são madeira e Mármores. Eles não dependem de uma imagem pois são gerados matematicamente.

Esqueleto - O esqueleto e os nomes hierárquicos são a mesma coisa. O esqueleto é um termo usado para facilitar a compreensão do sistema de vértices que podem deformar partes de um modelo.

Ligação do esqueleto- O esqueleto é formado por um número de ligações, cada ligação tem um Osso associado e um nó no seu fim. Cada osso é amarrado a outra articulação no nó ou "raiz".

Intensidade de brilho - O polimento de uma superfície é simulado pela intensidade de brilho. Basicamente quanto mais polida uma superfície maior será a intensidade de brilho que ela possuirá.

Vértice - Um ponto distinto no espaço 3D representado por um ponto amarelo ou vermelho se selecionado ou deselecionado respectivamente.


Quad View

Quatro vistas

As três vistas com botões nomeados com Superior, Anterior e Lateral são as vistas usadas para o trabalho. Esses botões quando clicados alternam para a Vista simples, útil para editar de forma mais refinada. Vc pode Redimensiona as quatro vistas Clicando na interseção das vistas.

A vista Câmera exibe a perspectiva renderizada do modelo via OpenGL.

A barra de status na parte inferior tem dicas para cada operação no Designer. A parte da barra a direita mostra o número de vertices e faces selecionados.


Single View

Vista única

O Animador exibe assim uma vista única.

A barra de status na parte inferior da tela mostra informações de ajuda. A parte esquerda da barra mostra o Ator selecionado. A parte direita mostra informações sobre a ferramenta usada, botão ou área que o mouse está atuando.

Os botões chamados Superior, Anterior, Lateral e CÂMERA localizados na parte superior das respectivas vistas é que são usados para alternar entre as vistas única e quatro vistas.

A paleta de quadros da câmera está abaixo da vista câmera e controla qual quadro da animação está sendo exibido e também executa previsualizações rápidas.


Objects

Atores

Há 12 tipos de atores no módulo Animador. Cada ator é representado por um ícone. Os atores Câmera, Luz e Alvo possuem ícones facilmente identificáveis. Os atores Modelo, Morfose, e Robô são representados por cubos limitados, malhas ou contornos. Os atores Atmosfera, Efeito e Diretor não possuem representação visual, ator CSG é sempre exibido como um cubo limitado e o solo por um ponto, retângulo ou linha. O ator caminho é representado por um segmento de linhas conectadas por nós.

Os três primeiros, modelo, morfose e robô são visíveis na renderização se possuirem um avatar. Os avatares são desenhados no Designer.

O grupo composto por atmosfera, solo e CSG são visíveis apenas em certas condições especiais e são simples.

O Efeito Pós-processo é um tipo de ator que não é visível nas vistas.

Os atores restantes , Câmera, Luz, Caminho, Diretor e alvo não são visíveis na renderização mas são de importância vital na animação.

Modelo
Este ator possui um avatar que é o modelo criado no Designer. Um ator modelo pode ter mais de um avatar numa animação. Se o ator mudar de avatar, e eles foram compatíveis o Ator será instruido para morfosear gradualmente para a nova forma na linha do tempo especificada.

Morfose
Possui um avatar feito no Designer, mas dois ou mais modelos podem ser usados para determinar uma morfose. Um conjunto de modelos são manipulados como se fossem uma única entidade.

Câmera
Simula uma câmera na animação e é por onde o Render irá gerar as imagens. Pelo menos uma câmera deve existir e muitas podem haver lembrando que apenas uma de cada vez pode ser visualizada.

Alvo
São úteis para definir o ponto onde a câmera irá apontar e para definir ações especiais que precisam ocorrer num mesmo lugar em tempos diferentes.

Luz
Provê a iluminação para a animação, se múltiplas luzes estão presentes dimensione cada uma delas. Luzes podem ou não lançar sombras, luzes spots possuem cones para direcionar a luz, luzes também são usadas para definir locais de efeitos especiais de pós-processo.

Caminho
É usado para indicar um movimento curvo de um ator. A velocidade é especificada na Velocidade da curva. Caminhos podem ser abertos, fechados ou lidos de uma arquivo .PTH. Caminhos não são visíveis na renderização.

Atmosfera
Forma uma plano de fundo desde a parte superior da vista. Apenas um ator atmosfera é permitido em cada animação.

Solo
É um plano horizontal que se extende ao infinito em todas as direções. Pode possuir múltiplos mapeamentos e texturas. Apenas um solo é permitido por animação e ele não pode ser manipulado (rotacionar por exemplo). Um retângulo irá representar o solo na vista superior e um linha na vista lateral.

Efeito pós-processo
Éles adicionam um processo a imagem previamente renderizada. Esse processos podem ser, por exemplo: Reflexos de lentes, Efetiots especiais de vídeo, neblina, etc.

Robô
Usa um modelo como um esqueleto. O esqueleto pode ser manipulado.T

CSG
Representa algumas geometrias que normalmente requerem um número grande de faces, esses atores criam esses modelos básicos com poucas faces mas que na renderização apareçam bem curvos. Atores CSG podem possuir esferas, discos, cilindros ou tubos com avatares. Nota: CSG não lançam sombras ou aparecem em reflexos.

Diretor
É usado para especificar qual câmera está ativa no momento. Apenas um diretor para cada arquivo é permitido.


Camera View

Vista câmera

Exibe uma renderização rápida da câmera ativa no quadro especificado.

O numero do quadro exibido é especificado usando os controles de animação da vista câmera na parte inferior da vista câmera.

A vista por padrão usa OpenGL. Vc pode alternar para Vista câmera em malha pressionando F11.


OpenGL Shaded view

Vista OpenGL

Mostra a vista Câmera com sombreado

OpenGL com mapeamento aplicado

F11 ou clique direito escolhendo a opção "Ocultar/Exibir vista câmera OpenGL.

Desligar o mapeamento diminui o uso da memória e a vista fica mais veloz.

OpenGL com mapeamento desligado


Wireframe Camera View

Vista câmera em malha

Mostra a vista câmera renderizada em malha.

Pressione F11 para exibir em malha ou clique direito na janela da Câmera.


Hidden Line Camera View

Linha oculta

Exibe a vista câmera com as linhas ocultas (atrás das faces dos objetos) removidas.

Essa função pode ser acessada com o clique direito na janela e escolhendo-a do menu flutuante.

Linha oculta

Normal

Para exibir a vista OpenGL novamente pressione F11 ou clique direito na vista câmera e escolher exibir OpenGL.


Quick Render

Renderização rápida

Renderiza com mapeamento, texturas, reflexões, etc e anti-serrilhado médio. F12 (ótimo para previsualizações rápidas).

Dica: Renderização rápida é muito mais veloz em monitores com 16 milhões de cores.


Camera View Animation Controls

Controles de animação da vista câmera

Possibilita vc especificar qual o quadro atual, mover para os quadros chaves e previsualizar animações.

Barra de indicação do quadro
Ir para o quadro-chave anterior
Ir para o próximo quadro-chave
Executar animação
Exibir rápido usando cubo limitado
Número do quadro


Frame Toggle Bar

Barra da trilha dos quadros

Clique e arraste no indicador para navegar através dos quadros da animação, ou clique numa área especifica para ir a um quadro aproximado.


Go to Previous Keyframe

If an Actor is selected and it has a Costume assigned, then clicking this button will set the current frame to the keyframe at the beginning of the timeline. If the Move tool is active then the keyframes of the Movement timeline are used by this function. Similarly for the Rotate and Scale tools. If the Selector, Pan or Zoom tools are active then the Actor’s Costume timeline is used by this function.


Go to Next Keyframe

Ir para o próximo quadro-chave

Vai para o próximo quadro-chave na linha do tempo atual. Dependendo da ferramenta usada o botão irá para o quadro-chave relacionado.

Se o ator estiver selecionado e possuir um avatar, clique este botão para adicionar um quadro-chave na linha do tempo. Se a ferramenta mover estiver ativa então os quadros-chaves serão criados quando usar a ferramenta, o mesmo vale para as ferramentas Rotacionar e escala. Se o selecionador, panorâmica ou zoom estiverem ativos, a linha do tempo avatar será usada por esta função.


Play Animation

Executar animação no modo malha

Previsualiza a animação na vista câmera em modo malha.

Se a animação estiver muito lenta, use a função previsualizar sob o menu quadro. Clique em parar e defina o quadro atual até o quadro que deseja ser o último. Clique em cancelar para manter o quadro iniciado como o quadro atual.

Nota
Para previsualizar a animação com OpenGL, selecione atualizar visualizador OpenGL através do menu janela ou pressione F12.


Play Bounding Box

Executar animação no modo cubo limitado

Previsualiza a animação usando cubos limitados para representar os objetos na cena.


Frame Number Button

Botão quadro número

Mostra o número do quadro atual.

Vc pode especificar um quadro específico clicando no botão e escrevendo o número do quadro desejado.


OpenGL Settings

Definições OpenGL

Definições da vista Câmera OpenGL.

Matiz plana nas faces - Renderiza o modelo sem suavização.

Mapeamento rápido - Aumenta a velocidade de renderização se estiver ativo exibir mapeamento.

Exibir mapeamento - Renderiza o modelo com mapeamento aplicado.

Anti-serrilhado - Renderiza a imagem sem serrilhamento dos pontos, porém aumenta o uso de memória.

Acelerado por Hardware (sem mapeamento) - OpenGL renderiza mais rapidamente se houver um hardware dedicado instalado. Mas não irá renderizar mapeamento.

Luz de profundidade - Aumenta a saturação da iluminação.

Neblina - Renderiza com neblina.

Filme a 256 cores - Renderiza em 256 cores.


Animator Tools

Ferramentas

Funções das ferramentas do módulo Animador do OFX.

Clique na ferramenta para mais informações sobre ela e sua funcionalidade.


Object_Selector_Tool

Selecionador de objetos

Seleciona o Ator clicando no mesmo nas vistas do programa.

A seleção é indicada pela cor. Um ator selecionado fica amarelo.

Duplo-clique num ator exibe sua caixa de diálogo apropriada..


Vertex_Selector_Tool

Selecionador de nós

Seleciona e move o no do Caminho, nó da trilha interpolada suave, ou ligação do robô.

Essa ferramenta é sensível ao tipo de ator onde é aplicada.


Hand_Tool

Ferramenta Panorâmica

Move a vista pelo espaço. Duplo clique centraliza a vista no Curso3D.


Zoom_Tool

Ferramenta Zoom

Reduz ou amplia a vista.

Clique e arraste para definir uma região de zoom.

Duplo-clique exibe todos os atores no centro da vista.


Move_Tool

Ferramenta mover

Move o Ator selecionado para uma nova localização.

Duplo clique abrirá a caixa de diálogo Mover. Note que um ator precisa estar selecionado para a caixa abrir.

Para mover o Ator interativamente 1 "pixel", use as teclas de seta. Para mover 5 "pixels" pressione e segure a tecla SHIFT enquanto usa as teclas de seta.


Rotate_Tool

Ferramenta rotacionar

Rotaciona o Ator selecionado sobre seu ponto pivô.

Clique e arraste na vista para rotacionar.

Duplo clique abrirá a caixa de diálogo Rotacionar. Note que o ator precisa estar selecionado.

Para rotacionar de grau em grau, use as teclas de seta. para rotacionar de 5 em 5 graus, segure a tecla SHIFT e use as teclas de seta.


Scale_Tool

Ferramenta escala

Esta ferramenta escalona o Ator selecionado sobre seu ponto pivô.

Na caixa de diálogo escala vc pode indicar em qual coordenada ele irá escalonar. Clique em qualquer vista para escalonar o ator.

Duplo clique na ferramenta escala para ativar a caixa de diálogo escala. Um ator precisa estar selecionado para a caixa aparecer.


Insert_Tool

Ferramenta inserir

Inseri Atores no Animador.

Ators são inseridos na localização do Cursor3D.


Insert Model

Inserir modelo

Inseri Modelos no Animador na localização do Cursor3D.

Selecione o modelo através da caixa de diálogo que se abrirá.

Modelos são adicionados com a nomeclatura: Model1, Model2, etc. Modelos podem ser renomeador através do menu Editar > Renomear ator...

Modelos pode ser inseridos com um nome específico através do menu Editar > Inserir ator... (Ctrl+A).


Insert Morph Cycle

Inserir morfose

Inseri Morfoses dentro do Animador na localização do Cursor3D.

Uma morfose é composta de um conjunto de modelos que são manipulados com se fossem um.

Um arquivo de sequência Morfose (com extensão .ANI) será requisitado enquanto cria um linha do tempo avatar para o ator morfose. Vc será perguntado sobre o número de vezes que a sequência repetirá na animação.

Para entender o use de um morfose siga o exemplo abaixo:

Uma sequência de caminhada é construida com 4 modelos de uma figura que formam um ciclo a cada 18 quadros, fechando o looping.

No Q-chave o ator basico "walk" possue 5 avatares e morfoses na seguinte ordem:

Quadro | Avatares do Ator "walk"
1 | step1.mfx
6 | step2.mfx
10 | step3.mfx
14 | step4.mfx
18 | step1.mfx (novamente) para completar o ciclo)

Suponhamos agora que vc procure criar uma animação onde as figuras caminharão seguindo um caminho de 15o quadros. Não é interessante criar quadros-chaves a cada 5 quadros, não acha? É aí que entra a morfose em ciclo. Vc usará a nossa simples animação para criar a figura andando.

A primeira coisa que nos precisamos é gravar a morfose básica para um arquivo, para isso selecione "Gravar como uma morfose" a partir do menu flutuante do ator "Walk".

Com essa informação gravada a sequência de imagens podem ser usadas vez após vez. Quando for inserida em uma animação ela pode ser repetida e escalonada para preencher todo o tempo. Considere agora nossa animação de 150 quadros onde inserimos um ciclo de morfose de 18 quadros repetindo 8 vezes, e tudo com um único comando inserir!

Note que a sequência não repete exatamente 8 vezes no tempo de 150 quadros (em fato repete 8,33333), quando a sequência é inserida ela automaticamente é extendida para preencher o tempo necessário.

Sendo assim, muitos ajustes podem ser feitos para a velocidade de uma animação, como tudo no 3D, a experimentação é o melhor caminho para aprender.


Insert Camera

Inserir câmera

Insere uma câmera no Animador na localização do Cursor3D.

Câmeras são adicionadas com a nomeclatura: Camera, Camera2, etc. Câmeras podem ser renomeadas através do menu Editar >Renomear ator....

Câmeras podem ser inseridas com nomes específicos usando o menu Editar > Inserir ator... (Ctrl+A).

Note quea uma câmera selecionada pode ser ativada através do menu Editar > Câmera ativa (C).


Insert Target

Inserir alvo

Inseri alvos no Animador na localização do Cursor3D.

Alvos são usados para apontar Câmeras e luzes spots para um ponto específico sem usar um Modelo visível.


Insert Light

Inserir Luz

Inseri Luzes no Animador na localização do Cursor3D.

A caixa de diálogo Definições da luz permite especificar o tipo de luz a ser inserida.

Muitas luzes inseridas aumentarão o tempo de renderização e podem causar excessiva saturação na imagem (muito brilho). Se nenhuma luz estiver presente o renderizador automaticamente ligará uma luz seguindo a posição da Câmera.


Insert Path

Inserir Caminho

Inseri um Caminho no Animador na localização do Cursor3D.

A velocidade de uma ator no caminho é especificado em velocidade no caminho. Caminhos podem ser abertos, fechados ou lidos de um arquivo PTH

O número de pontos de controle de um caminho pode ser editado com a ferramenta Selecionador de nós. Um caminho é selecionado clicando nele.


Insert Sky

Inserir atmosfera

Inseri uma atmosfera no animador.

Um ator atmosfera é inserido desde a parte superior em frente até o plano de fundo. Nenhum movimento, rotação, eescala é necessária ou possível para a atmosfera. Somente um ator atmosfera é permitido por animação.

O tipo de Atmosfera usada é especificada na caixa de diálogo Definições da atmosfera.


Insert Ground

Inserir Solo

Inseri um Solo no Animador na localização do Cursor3D.

O Solo é especial por que extende ató o infinito em todas as direções e pode ter sombras lançadas por atores. A sombra no solo é obtida sem necessidade de Raytrace. Ainda assim aumentará um pouco o tempo de renderização.

A caixa de diálogo Definições do Solo permite especificar o tipo de solo e suas propriedades.

Não é possível inclinar o solo, vc pode criar a ilusão tombando uma câmera.


Insert Image Effect

Inserir Pós-processo

Inseri um efeito de pós-processo escolhendo-o da caixa de diálogoSelecionar módulo de processamento de imagem

Alguns efeito mais usados são Reflexos de lente, Neblina, aura, etc. A renderização consumirá mais tempo para calcular.

Qualquer número de pós-processos podem ser adicionados na animação, e aplicados na ordem desejada nos quadros.

Cada um tem parâmetros particulares e informações relevantes que são gravadas no arquivo da animação do OFX.

Note que Vídeo e XVideo possuem um número grande de efeitos. Cada efeito é uma arquivo EFX na pasta PSOTPRO.

Nota importante: Todos os efeito requerem que as opções Tela cheia e armazenamento Z esteja ligados. Elas podem ser acessadas na caixa de diálogo do renderizador na seção opções. Elas estão ligadas por padrão.


Insert Robot

Inserir robô

Inseri um ator Robô no Animador na localização do Cursor3D.

Uma caixa de diálogo é mostrada requisitando o nome do modelo MFX que será usado como robô. O arquivo MFX precisa possuir um esqueleto.

Robôs são efetivamente morfoses, no entanto eles não são metamorfoseados de um robô para um modelo diferente. Uma ator robô precisa de uma sequência de pequenas linha do tempo Avatares com o mesmo robô em diferentes posições. O Robô é manipulado nos quadros-chaves para cada linha do tempo.

Veja mais em:
Posicionando Rob6o


Insert CSG Object

Inserir CSG Actor

Inseri um ActorCSG no Animador na localização do Cursor3D.

Escolha o tipo de AtorCSG a partir de uma caixa de diálogo.

Atores CSG podem ser aditivos ou subtrativos, Atores CSG com tubo e disco não possuem volume para fazer uma subtração. A opção adicionar é automaticamente selecionada pelos volumes CSGs. Se vc intencionar realizar um corte em outro CSG, então clique o botão Subtrair, caso contrário clique o botão adicionar.


ZZZZ_INCOMPLETE

Help is not available on this topic yet.


Render Tool

Ferramenta renderizar

Clique na ferramenta e a caixa de diálogo aparecerá.


Render Control Tab Page

Renderizador OpenFX

Resolução - Escolha a resolução. Vc pode escolher de uma das pré-definições ou digitar o número de "pixels" para a imagem.

Anti-serrilhado - Escolha essa opção para definir o nível do anti-serrilhado. Basicamente anti-serrilhado suaviza o contornos dos objetos na renderização de forma a disfarçar os "pixels". Quanto maior o nível, maior o tempo de renderização.

Acelerar o Anti-serrilhado - Pode provocar resultados insatisfatórios. Experimente, se o resultado for bom para a imagem que vc está usando ele pode diminuir consideravelmente o tempo de renderização.

Misturar cores - Escolha o tipo de mistura que na verdade é otimização da paleta da imagem, imagens de 24 bit não precisam de mistura. Já imagens de 256 cores sim, essa é uma forma de evitar o "Banding" (cores num degradê quebradas por exemplo).

Há vários métodos de mistura. O "Floyd-Steinberg" é mais apropriado para imagens estáticas. "Noise Dithering" é mais apropriado para animação.

Formato da imagem - Selecione o formato. Isso irá determinar a paleta de cores automaticamente. GIF usa um formato de 8bits, TGA e TIF 16 bit ou 24 bit.

Tipo da animação - Selecione o formato.FLIC (256cores), AVI (padrão Windows), ou GIF animado (256cores). Note que arquivos FLC não possuem compressão se a resolução for maior que 640x480 "pixels".

Nome da imagem - Nome da imagem e pasta onde será gravada. Pasta padrão é "Render".

Nome da animação- Nome da animação e pasta onde será gravada. Pasta padrão é "Movies".

Quadro atual - Especifica qual quadro da animação será renderizado.

Alcance - Especifica um número de quadros que será renderizado.


Render Options Tab Page

Opções do Renderizador

Linha oculta - Renderiza a imagem desconsiderando as faces e arestas atrás dos modelos. Acelera a renderização.

Reflexo do solo com anti-serrilhado - Para reflexões do solo sem Raytrace.

Sem suavização - Desconsidera a suavização das faces e renderiza todos os cantos. Acelera a renderização e é possivel que ocorra desativação de algum mapeamento.

Reduzir Saturação - Pós-processo que remove cores 'ilegais' para o formato NTSC.

Escrever GIFs entrelaçado - Grava os GIFs no modo entrelaçado. O formato será o GIF 87.

Solo no canal alpha - Cria um alpha com o solo na imagem.

Escrever arquivo alpha separadamente - Escreve um arquivo alpha para cada imagem. Solo não está incluido.

Use armazenamento da tela cheia - Renderiza todos os "pixels" para um "buffer" de memória antes de cria o arquivo temporário. Ele aumenta a velocidade do Renderizador e imagens de Pós-processo requerem isso. Por outro lado exige um número alto de memória RAM.

Armazenamento Z - Cria um "buffer" com informação da profundidade da imagem. Use-o se a animação usa um pós-processo como neblina que requer essa opção ligada.

Usar armazenamento do ID do ator - Cria um "buffer" para o processo externo que identifica qual ator está visível na imagem final.

Exibir imagem enquanto renderiza


Render Settings Tab Page

Definições do renderizador

Velocidade da animação - Define a velocidae para arquivos FLI/FLC. O Valor é em unidade "jiffies", zero faz a animação rodar o mais rápido possível.

Ângulo da suavização

Luz ambiente % - Substitui a luz ambiente especificada no ator Atmosfera. Um máximo de 30% trabalha bem, valore maiores que 70% produz imagens com alto contraste.

Densidade da sombra % - Especifica a escuridão das sombras lançadas no solo. Define a densidade da sombra. 50% é o padrão, 100% produz sombras completamente negras, 0% não aparece sombra.

Armazenamento da Luz Spot - Altera a resolução das sombras lançadas pela luz. As sombras lançadas exigem memória. Um valor de zero impica que a luz não lança sombras. Vc pode calcular definições para resultados melhores multiplicando o número de "pixels" por 4 (isto é 320x200x4=256,000 bytes requiridos).

Ângulo da linha de ilustração -Ângulo máximo para as faces planas no modo Ilustração. Se duas faces são adjacentes e o angulo entre elas é menor que este valor o contorno não será desenhado. Um alto valor resultará em apenas um contorno no modelo na imagem, que pode ser útil para imitar o estilo "Cartoons" para desenho animado.

Valor do Ruído - Granula a imagem.

Desfoque de movimento - Valores altos geram desfoque de movimento. O alcance normal é 0-10. Quando um número fora desse alcance é definido a integração do desfoque inicia.

Dígitos nos nomes dos arquivos - Especifica o número do quadro no nome do arquivo renderizado.

Qualidade da imagem JPEG - Especifica a qualidade da compressão JPEG. Qualidade alta cria arquivos de grandes tamanhos.

Especificar números de processadores - Ativa seleção de 1-16 processadores ou coloca o renderizador automaticamente para determinar o número de processadores e atribuir a cada um trabalho.

Definições pessoais - Gravar e ler definições personalizadas.


Render Trace Tab Page

Raytrace

Opções para renderização utilizando Raytrace.

Traçar sombras - Todas as sombras são automaticamente calculadas.

Traçar reflexões - Todas as superfícies reflectivas autmoticamente são calculadas.

Traçar refração - Todas as superfícies com refração autmoticamente são calculadas.


Menus

Todas as funções do módulo Animador.


File Menu

Menu Arquivo

Controla a manipulação do arquivos do OFX.


File New

Arquivo novo

Esse comando limpa todas as informações da animação e inicia uma nova animação com as informações padrões de inicialização. Se o arquivo onde está trabalhando não foi gravado vc será perguntado se deseja gravar as alterações antes de iniciar um arquivo novo.


New From Template...

Novo a partir do modelo...

Existem alguns modelos da animação simples que podem ser lido daqui. São úteis para criar uma animação rápida. Escolha na caixa de diálogo a mais apropriada para sua necessidade.


Standard One Frame View

Vista padrão de único quadro

Gera uma animação de quadro único com uma câmera, luz, modelo e atmosfera.

Vc deverá especificar o modelo a ser usado.


One Frame with Ground

Um quadro com solo

Esse modelo gera um único quadro de animação com uma câmera, luz, modelo, atmosfera e solo.

Vc deverá escolher um modelo e cor do solo.


Animate Rotating Model

Modelo animado de rotação

Essa "template" gera uma animação com uma única câmera, luz, modelo e atmosfera.

Vc será requisitado para escolher um modelo e o número de quadros para a animação depois de de selecionar essa "template". A animação consistirá do modelo selecionado rotacionando sobre os eixos verticais pelo número de quadros escolhidos.


Model on open path

Modelo num caminho aberto

Gera uma animação com uma câmera, luz, atmosfera e um modelo movimentandos-se num caminho aberto.

Vc deverá especificar o model e o número de quadros da animação.

Note que selecionador de nós pode ser usad para modificar e adicionar pontos no caminho.


Model on closed path

Modelo no caminho fechado

Gera uma animação com uma câmera, luz, atmosfera, e um modelo movendo-se num Caminho fechado.

Vc deverá especificar o modelo é o número de quadros da animação.

Note que selecionador de nós pode ser usad para modificar e adicionar pontos no caminho.


Model on loaded path

Modelo num caminho lido

Gera uma animação com uma câmera, luz, atmosfera e um modelo movimentandos-se num Caminho lido.

Vc deverá especificar o modelo, o número de quadros da animação e o caminho a ser usado.

Note que selecionador de nós pode ser usad para modificar e adicionar pontos no caminho.


Travellers

Viajantes

Esse modelo permite facilmente gerar um conjunto de modelos viajando numa trilha.

Ótimo para criar um logotipo voando com letras independentes.

Selecione o número de quadros, tipo caminho lido, modelo que será o cabeça do processo, e modelos que o seguirão. Pressione cancelar quando todos os modelos forem lidos.

Note que a ferramenta selecionador de nós pode ser usada para modificar a forma e o número de pontos no caminho.


Create Spanning View

Este modelo gera múltiplas vista 3D de um modelo para o visualizador 3DVIEWER.

Escolha o modelo, crie a câmera desejada, atmosfera, iluminação e renderize uma série de imagens GIF. O programa 3D viewer (3DView.exe é encontrado junto ao OpenFX) pode visualizar a sequência de imagens renderizadas com esse modelo.


Open Animation Dialog

Abrir...

Abre uma caixa de diálogo para carregar uma animação gravada.

A extensão para animação é .OFX

Se vc já estiver trabalhando num arquivo uma mensagem pedirá para gravar ou não as modificações feitas.


Save Animation Dialog

Gravar

Este comando grava a animação atual no arquivo aberto corrente.

Use este comando para gravar frequentemente seu trabalho a cada alteração.


Save As... Animation Dialog

Gravar como...

Este comando grava a animação atual num novo arquivo OFX.


Export Animation Dialog

Exportar Animação

Escreve uma animação ou roteiro de quadros que dirigirão o Renderizador em modo remoto para produzir uma animação.

O roteiro precisa possuir a extensão SCR. Ele é um arquivo texto ASCII que pode ser transferido a outro computador ou estação de trabalho para renderização. Muito útil para renderizar segmentos da animação em múltiplos sistemas.


VRML_HELP

Exportar modelo Realidade Virtual

Existem 2 elementos no exportador VRML, o exportador VRML do Designer que escreve os vértices e faces do modelo, e o exportador VRML do Animador que escreve um arquivo VRML colocando os modelos numa cena e adicionando plano de fundo, câmeras e caminhos.

Exportador VRML Designer

Use essa opção quando partes de um modelo estiver selecionada.

  • Indexação
  • Usar Prefixos
  • Digitos de Precisão
  • Criar Normais
Indexação

Faz o arquivo VRML ser editado ou lido num editor de textos com mais facilidade. Por outro lado cria uma arquivo maior.

Prefixo URL da imagem

Cada imagem é guardada com um caminho completo da pasta onde está.

Digitos de precisão

As coordenadas dos vértices são gravadas num formato de ponto flutuante, com esta opção vc pode escolher como serão usadas as unidades. Por exemplo, se 3 dígitos de precisão forem usados as coordenadas serão escritas no formato 4.533, 16.732 etc.

Normais

Um conjunto de normais podem ser gerados baseados nos ângulos das faces para cada vértice. Somente faces que possuem suavização são analizadas.

Notas importantes

Para criar representações VRML mais eficientes siga as convenções anotadas abaixo:

  • Uma forma VRML separada é criada para cada entrada na hierarquia do esqueleto. Sendo assim, um modelo complexo pode ser dividido em subunidades para cada nó (osso). Isto é essencial se um mapeamento é aplicado a qualquer face no modelo e ajudará na redução do tamanho do arquivo VRML.
  • Cada face atibuida a um nó no esqueleto é testada para verificar se existe um mapeamento aplicado. Visto ser somente possível usar um mapeamento para cada face.
  • Outro passo importante é ver se todos os mapeamentos são fixados, pois todos precisam ser desse tipo.
  • Reflexos, Refrações, relevos e texturas não são exportadas.

Exportador VRML do Animador

As opções adicionais são:

  • Vistas de acordo com a posição da câmera. Essa vista será acessada pelo browser.
  • Câmera com sensor de tempo. Posição e orientação são escritas para a câmera ativa no intervalo regular de quadros da animação.
  • Plano de fundo do ambiente usa seis imagens definadas nas URLs
  • Se atmosfera e solo estão incluidos na animação então eles serão representados no arquivo de saída do VRML.


Quick Render

Renderização rápida

Clique direito na vista Câmera e escolher Renderização rápida ou usar F12. A renderização mostrará, mapeamento, texturas, reflexos, etc.

Note que a opção no menu não estará disponível se o recurso Sombreamento via OpenGL estive ligado.

Dica: Renderização rápida será mais rápida se o monitor estiver no modo 16 milhoões de cores.


Render

Renderizar

Inicia a renderização sem passar peloConfiguração da renderização ou Ferramente renderizar.


Render_Setup

Render Setup...

Launches the Renderer.

Select the desired settings in the Control, Options, Settings, and Tracing tab pages of the Renderer dialog. Press the Render button at the bottom of the Renderer dialog to start rendering. Note that test renders be done quicker using the File > Quick Render (F12).

The renderer defaults to a Scanline Phong renderer. Various levels of Ray tracing can be enabled in the Tracing tab page. Phong rendering is suggested in most cases since ray tracing is notoriously memory and time intensive.

The renderer is multi-threaded and will benefit greatly if additional processors are installed in the system. Rendering on a two processor system will almost be twice as fast as with one processor.


Print

Imprimir

Seleciona uma imagem para imprimir.

É uma opção simples para rapidamente imprimir imagens renderizadas, screenshots, mapeamentos e outras imagens do projeto. Ele converte a imagem para preto e branco e usa a impressora padrão para imprimir.


Preferences

Preferências

Specifica as preferências Geral, Inicialização, pastas dos modelos, e pastas das imagens para o módulo Animador.


Preferences General Tab Page

Preferências Gerais

Redesenhar rápido - permite uma subrotina exibir linhas incompletas, aumentando grandemente a velocidade da exibição.

Preparar arquivo desfazer - Permite operações voltar. Desabilitar aumenta a velocidade das operações.

Exibir Solo apenas como horizonte - Se ticado, o solo será mostrado na Vista Câmera em modo malha com uma linha horizontal. Se não ticada, o solo será mostrado como uma grade escalonada de acordo com as Definições de eescala do solo.

Colocar paleta de ferramentas a esquerda - Clique direito nas ferramenta para mostrar opção.

Usar ícones miniaturas - Os ícones serão menores para ganhar espaço de tela para o modelo.

Exibir legendas nos comandos

Mudar tamanho das vistas para exibir todos os atores antes de um novo ser lido - Automaticamente redimensiona a janela para mostrar todos os atores.

Usar OpenGL para pôses do robô - Exibe a janela da Vista robô com OpenGL.

Definir detalhe da malha - Se ticado, mostrará os detalhes de acordo com o valor inserido na caixa ao lado.

Não ticado, exibirá no valor padrão (mai aplicável).


Preferences Startup Tab Page

Preferências iniciar

Especificações da inicialização do programa.

Use a última posição das janelas- Grava a última posição das janelas para abrir da mesma forma da próxima vez.

Execute animação inicial antes de começar - Se ticado, qualquer arquivo chamado STARTUP.OFX (na pasta raiz) automaticamente é previsualizada na vista câmera por 4 segundos.

Exibir tela Splash por ______ Segundos - Define o tempo (N = número de segundos) que a tela inicial será exibida. Se 0 a tela não aparecerá, se 1000, então permanecerá indefinidamente até clicar numa opção.


Preferences Model Paths Tab Page

Preferências pasta dos modelos

Especifica a localização da pasta onde os modelos são armazenadas para o renderizador poder encontrá-las.

Permite o renderizador encontrar os modelos se não estiverem na pasta original gravada. Por padrão a pasta é o subdiretório MODELS, vc pode especificar uma lista em ordem de pastas.


Preferences Image Paths Tab Page

Preferências pasta das imagens

Especifica a localização da pasta onde as imagens são armazenadas para o renderizador poder encontrá-las.

Permite o renderizador encontrar as imagens se não estiverem na pasta original gravada. Por padrão a pasta é o subdiretório MAPS, vc pode especificar uma lista em ordem de pastas.


Exit Animator

Sair do Animador

Esta função fecha o módulo Animador e todos os outros módulos do OFX.

Se alguma modificação no trabalho não foi gravada, uma caixa de diálogo será exibida para confirmar a gravação ou não antes de fechar o módulo.


Edit Menu

Menu editar

Descreve as funções de edição do Animador.


Undo

Desfazer

Desfaz a última operação realizada.

Lembre-se que não funciona com todas as funções, algumas não podem ser desfeitas.


Select Object...

Selecionar ator..

Seleciona um Ator pelo nome para operações apropriadas.

Permite vc selecionar um ator apropriado. Muito útil para trabalhar com animações que contenham um grande número de atores.


Insert Object...

Inserir ator..

Adiciona um novo Ator na animação..

Selecione o tipo de ator desejado, e atribua um novo nome ou aceite o padrão. Novos atores de um mesmo tipo são numerados quando criados.

Atores são inseridos na localização do Cursor3D.


Delete

Apagar

Apaga o Ator selecionado da animação.


Info

Exibe informações básicas sobre o Ator selecionado.

Cada tipo de ator possui uma caixa de diálogo diferente de informação.


Rename Object...

Renomear ator...

Permite vc renomear oAtor selecionado.


Costume

Avatar

Esse comando é usado para adicionar ou apagar um avatar atribuido a um ator. Uma caixa de diálogo com uma lista irá aparecer.

Se o ator já possuir um avatar para o quadro atual então uma mensagem dizendo que o Avatar já existe será mostrada. Caso contrário uma ação será tomada dependendo do tipo de ator.

Por exemplo, se for escolhido um Ator modelo, uma lista aparecerá contendo os modelos .MFX para vc escolher o avatar.

Se um avatar for adicionado, uma linha do tempo avatar será criada no quadro atual.


Special Effect...

Efeito especial...

Este comando é usado para aplicar um efeito especial a um modelo durante o processo de renderização.

É importante notar que o efeito especial só pode ser visualizado na renderização.

Efeitos especiais deformam os vértices de um avatar ou faz partes do modelo desaparecer. Como esses efeitos ocorrem no nível do avatar as linhas do tempo para a posição, rotação e tamanho são completamente independentes. No entanto, o efeito é muito dependente do design do modelo que o ator está usando como avatar. O número e tamanho de faces usadas é o mais importante fator nos efeitos. A ordem em que as faces fora criadas no Designer influenciam bastante os efeitos "materializadores". E efeitos como ondas não serão visíveis por exemplo se passarem por um retângulo que consiste de dois triangulos formando faces. Subdividindo e criando mais faces apresentará o efeito como desejado.

Efeitos podem ser adicionados ou alterados editando a linha do tempo do avatar do modelo.


Build Effect

Efeito materializar

Cria um modelo que vai materializando num intervalo de quadros especificado na vista câmera.


Buildto Effect

Efeito materializar para

Cria um modelo que vai materializando face a face na vista câmera.


Dissolve Effect

Efeito Dissolver

Faz o modelo ficar transparente gradualmente até desaparecer.


Explode Effect

Efeito explodir

Vc deve definir o centro da detonação, como os pedaços serão jogados e em qual gravidade, etc.


Fall Effect

Efeito queda

Faz o model cair sob uma gravidade. O comportamento e a elasticidade são facilmente ajustáveis.


Flap Effect

Efeito Golpe

Simula uma combinação dos efeitos onda e Modular para simular um golpe.

Um ator pode sofrer um golpe linear ou circular.


Modulate Effect

Efeito modular

Faz passar uma onda através de um eixo especificado do modelo fazendo os vértices del moverem radialmente.


Shake Effect

Efeito tremor

Faz o modelo tremer de cima abaixo.

Em baixas velocidades, o efeito cria a simulação representada acima (oscilação). Em velocidades altas, parece um terremoto.


Spring Effect

Efeito mola

Faz o ator com um avatar comprimir-se e então soltar-se em alta velocidade como uma mola de verdade.


Squash Effect

Efeito esmagar

comprime ou expande um ator com avatar numa direção especificada. Parece o efeito escala, mas esse efeito faz o modelo agir como uma bola de borracha quando apertada.

Esmagar na vertical

Esmagar na horizontal


Twist Effect

Efeito Trançar

O efeito trança o ator em volta de um eixo especificado.

Eixo superior/inferior


Unbuild Effect

Efeito desmaterializar

Faz o modelo desaparecer face a face.


Warp Effect

Efeito hiperespaço

Faz o modelo simular uma entrada ou saída do hiperspaço (na ficção científica, quando uma nave entra na velocidade da luz ou "buraco de verme").

Esse é relativamente uma versão mais lenta do efeito, Mas a altas velocidades o efeito cria um tipo de projeção fantástico.


Wave Effect

Efeito ondular

Faz o modelo ondular sob uma força ou onda.

Onda básica linear

Ondas ajustadas em distâncias e fusões.

Ondas circulares são usuais para representar objetos lançados na água.


Edit Model

Editar Modelo

Essa opção carrega o Designer se não estiver já ativado, e automaticamente lê o modelo (avatar) para ser editado.

O Animador continua ativo. É muito útil para ajustar texturas, pôses, etc.


Swap Model

Trocar modelo

Permite vc trocar um modelo por outro, preservando as posições, rotações e escalas aplicadas. Um exemplo do uso dessa opção é usar um modelo simples para montar a animação e trocar um por um complexo quando estiver pronta para renderização.

Selecione o modelo a partir da caixa de diálogo para substituir do ator selecionado.


Path Velocity Curve

Velocidade da curva

Permite vc controlar a velocidade e direção de Ator num Caminho.


Reverse Path Direction

Inverter direção do caminho

Permite vc inverter a direção de um Ator no caminho selecionado.


Activate Camera

Câmera ativa

Essa opção possibilita vc ativar a Câmera selecionada. O nome da câmera selecionada é exibida na barra de status.

Somente uma câmera pode ser ativada por vez.


Image Processor Effect Types

Tipos de efeito de pós-processo

Insere um efeito a partir da caixa de diálogo.

Desfoque - Desfoca a tela para simular movimento.

Profundidade de campo - Simula efeito fotográfico de desfocar o fundo e focar o objetivo.

Filtro - Altera a cor dos "pixels" de acordo com o parâmetro desejado após a renderização.

Reflexo de lente - Simula o efeito das luzes refletindo nas lentes de uma câmera.

Neblina - Simula neblinas e nevoeiros.

Aura - Adiciona uma aura na cor desejada.

Auréola - Adiciona uma auréola em volta das luzes.

Brilho - Adiciona um brilho para as luzes.

Laser - Simula um raio laser.

Campo estelar - Gera um campo estelar (móvel).

Estrelas - Cria o efeito de estrelas na animação (fixo).

Supernova - Simula o efeito de uma estrela em supernova.

Trilhas - Deixa uma trilha atrás de modelos em movimento na animação.

Video - Oferece 24 tipos de efeitos de vídeo.

Xvideo - 26 efeitos de vídeos adicionais.

Veja sobre adicionais pós-processos especiais.

Bola de fogo..

Luz volumétrica...


Channel Menu

Menu linha do tempo

Funções de controle e configuração da linha do tempo do Animador.


Add Movement Timeline...

Adicionar uma linha do tempo de movimento...

Adiciona uma linha do tempo de movimento para o Ator selecionado.


Add Rotation Channel...

Adicionar uma linha do tempo de rotação...

Adicion uma linha do tempo de rotação para o Ator selecionado.


Add Scaling Channel...

Adiciona uma linha do tempo de eescala...

Adiciona uma linha do tempo de eescala para o Ator selecionado.


Add Movement Keyframe

Adiciona um Quadro-chave de movimento

Torna o quadro atual um quadro-chave na linha do tempo de movimento dos Atores selecionados..


Add Rotation Keyframe

Adicionar um quadro-chave de rotação

Cria no quadro atual um keyframeQuadro-chave na linha do tempo de rotação dos Atores selecionados..


Add Scaling Keyframe

Adiciona uma quadro-chave de eescala

Cria no quadro atual um quadro-chave na linha do tempo de eescala dos Atores selecionados..


Shift All Keyframes

Alterar todos os quadros-chaves

Altera todos os quadros-chaves aumentando ou diminuindo o número específico de quadros.


Frame Menu

Menu Quadro

Funções que controlam os quadros de uma animação.


Go to...

Ir para...

Ir para um quadro específico. Atualiza a vista câmera para o quadro especificado.

VC também pode acessar a caixa de diálogo clicando no botão número do quadro nos controles da vista câmera.


Previous

Quadro anterios

Exibe o quadro anterior na vista Câmera e o torna corrente.


Next Frame

Próximo quadro

Exibe o próximo quadro da animação na vista câmera e a torna ativa.


First Frame

Primeiro quadro

Exibe o primeiro quadro da animação na vista câmera e o torna ativo.


Last Frame

Último quadro

Exibe o último quadro da animação na vista câmera e o torna corrente.


Set Animation Length...

Definir duração da animação...

Define o número de quadros na animação.

Quadros - Define a taxa de amostragem dos quadros onde NTSC é 30 quadros por segundo (fps) e PAL é 25 fps.

Extender - Qualquer linha do tempo onde um quadro-chave ocorre no último quadro é extendida para que o quadro-chave continue sempre sendo o último quadro da animação.

Escalonar - A duração de todas as linhas do tempo são aumentadas ou diminuidas de forma tal que mantenham a mesma proporção entre si na animação.

Vazios - Quando a animação é extendida permite que qualquer nova linha do tempo crie espaços vazios. Visto que atores câmeras podem ter somente um avatar, todas as câmeras automaticamente preencherão todos os espaços vázios disponíveis.

Talhar - Corta a animação após o último quadro. Qualquer linha do tempo que se extende além do último quadro é truncada e o quadro-chave é colocado no último quadro da animação e qualque linha do tempo após o último quadro é removida.


Wireframe Preview

Previsualizar em malha

Gera uma previsualização da animação em malha, mostrando as arestas dos avatares dos Modelos, e a pré-gravação indenpende da complexidade do modelo, vc verá sem interrupção por causa de memória.

Clique no botão Criar previsualização para gravar a animação respeitando a velocidade de exibição (fps).

Previsualizar primeiro quadro
Previsualizar quadros anteriores
Executar animação
Previsualizar próximo quadro
Previsualizar último quadro
Parar animação


Actions Menu

Menu Ações

Funções especiais do Animador.


Move...

Mover...

Permite mover Atores para coordenadas precisas baseados no ponto pivô do ator ou nó de controle.

Essa opção somente é disponível se o ator selecionado possuir uma linha do tempo posição e uma quadro-chave no quadro ativo. Caso contrário o menu não estará disponível.


Rotate...

Rotacionar...

Permite rotacionar Atores com precisão numérica baseadas no ponto pivô do modelo ou nó de controle.

Essa opção somente estará disponível se o ator possuir uma linha do tempo rotação e o quadro chave for o quadro ativo.


Scale...

Escala...

Permite escalonar Atores com um valor preciso baseado no ponto pivô dos mesmos.

É útil especialmente quando vc precisar modificar com valores específicos na animação.

Esta opção está somente disponível se o ator selecionado possuir uma linha do tempo escala e quadro-chave no quadro atual.


Snap Cursor to Selected Object

Travar cursor no ator selecionado

Move o Cursor3D para o ponto pivô do Ator selecionado.


Snap Object to Cursor

Travar ator no cursor

Move o Ator selecionado colocando-o com seu ponto pivô na posição do Cursor3d.


Spline Tween Mode

Modo interpolativo

Permite mover Ators numa trilha editável. As opções estão separadas na seção trilha e Direção.

Note que o modo interpolativo permite vc visualizar e editar a animação inteira sem caminhar quadro a quadro!

Somente movimentos interpolativos ou interpolativos suaves possuem uma trilha, qualquer outro movimento não possui modo de edição de trilha. Se eles forem movimentos interpolativos os segmentos na trilha serão linhas retas. Se forem interpolativos suaves os segmentos serão curvos. Se o ator selecionado não possuir nenhuma linha do tempo de movimento, linhas do tempo apropriadas serão adicionadas automaticamente.


View Menu

Menu Visualizar

Mostra as funções relacionadas as vistas do programa.


Show Keyframer

Exibir Q-chave

Mostra a janela do Q-chave para edição da linhas do tempo e quadros-chaves.


Dock Keyframer

Docar Q-chave

coloca o Q-chave na parte inferior da tela do Animador.

As linhas do tempo de um único Ator são exibidas quando o Q-chave está docado. Selecione o ator que vc deseja e veja suas linhas do tempo. Vc pode usar as barras de rolagem para ver a dos outros atores


Global Quickdraw

Visualização rápida

Exibe somente os vértices do Model nas vistas.

Visualização rápida ligada

Visualização rápida desligada


Draw Bounded

Visualização total / Visualização limitada

Alterna entre os tipos de vizualização da exibição do ator Modelo.

Cubo limitado


Full Selection

Alternar visualização

Modo Malha pode ser restrito ao ator Modelo específico se Visualização completa estiver ativa.

Selecionados - Exibe o modelo selecionado no modo malha. Demais modelos em Cubo limitado.

Deselecionados- Exibe o modelo deselecionado no modo malha.Demais modelos em Cubo limitado.

Todos - Exibe todos os modelos no modo malha.


Lock Bounded

Travar limitado

Trava o ator Modelo num cubo limitado.


Show Grid

Exibir grade

Liga ou desliga a exibição da grade nas vistas.

Existem 3 elementos na grade:
1. | O sistema de eixos, apresentados na cor branca, passando pelo ponto de origem (0,0,0).
2. | Uma grade respeitando cada unidade de coordenada.
3. | À 1/10 do tamanho (i.e. intervalos de 0.1) um grade pontilhada é mostrada em uma "cor escura (menos visível)".

Quando Zoom - é aplicado, a "grade pontilhada desaparece e uma nova grade "escura" é desenhada em intervalos de 10 unidades. Este processo continua até o zoom máximo.

O tamanho da grade é especificado na caixa de diálogo definições da grade.


Snap to Grid

Travar na grade

Trava o Cursor3D nos pontos da grade. A grade pode estar visível ou invisível.

Use a grade para mover o cursor3d em passos discretos enquanto desenha, move, etc.

Lembre-se que o zoom afeta o movimento do cursor3D.


Grid Settings...

Definições da Grade...

Define o tamanho da grade e se será visível.

O tamanho é definido pela unidade atual do Animador.


Camera Field of View

Profundidade de campo

Essa opção ligaou desliga a profundidade de campo de uma câmera, o efeito que desfoca o plano de fundo deixando o objeto frontal focado.

On

Off


Spotlight Cone

Cone da luz spot

Liga ou desliga o cone da luz spot.

ligado

Desligado


Coordinates

Coordenadas

Mostra a paleta de coordenadas do Animador.

Exibe as coordenadas do Cursor3D quando é movido. Escreva os valores para mover o Cursor3D nos campos desejados seguindo a instrução abaixo:

Move o Cursor3D para as coordenadas. Valores numéricos podem ser inseridos nos campos. Valores relativos (delta, ou dX, dY, dZ) automaticamente atualiza a coordenada absoluta e vice-versa.
Restaura as coordenadas iniciais do Cursor3D. Desfaz qualquer coordenada inserida nos campos.
Define a origem do sistema de coordenadas na posição do Cursor3D.
Define as unidades e o nome do sistema de unidades (padrão é cm).
Meça a distância a partir do Cursor3D até o ator selecionado mostrando-a na parte inferior direita da paleta.


3D Cursor

Cursor 3D

O Cursor 3D é usado para indicar uma posição exata no espaço 3D. Ele é posicionado nas vistas Superior, Anterior e laterais através do cursor do mouse (clicando numa área)

O Cursor 3D pode ser mostrado como uma cruz ou um alvo. Vc pode alternar usando a tecla F9.

Cursor 3D em cruz

3D Cursor 3D em alvo


Window Menu

Menu Janela

Opções e funções para controlar as janelas.


Zoom In

Zoom +

Amplia atores envolvidos pela ferramenta.


Zoom Out

Zoom -

Reduz a vista dos atores envolvidos pela ferramenta.


Set Default Zoom and Position

Definir Zoom e posição padrão

Reinicia os tamanhos e posições das vistas para a configuração padrão do Animador.


Large Camera View

Aumentar janela da Câmera

Aumenta a vista Câmera se alguma outra vista estiver no modo vista única.


Swap Viewpoint

Trocar vistas

Alterna as vistas entre Superior, Anterior, e lateral para Superior, Posterior, e outra lateral.


Close All Modules

Fechar todos os módulos

Esta função fecha todos os módulos abertos do programa OFX.


Reset Quad View Windows

Reiniciar quatro vistas

Volta as vista para os parâmetros da inicialização.


Modeler

Designer

Executa o módulo Designer.


Viewer...

Launches the Viewer module for displaying GIF, Targa (TGA) BMP, PNG and JPEG images.

Multiple images can be opened and viewed simultaneously.


FLIC Player...

carrega um módulo que visualiza filmes FLIC e FLI.


AVI Player...

Módulo para visualizar arquivos AVI.

Múltiplos filmes AVI podem ser abertos e executados simultaneamente.


Utilities

Utilitários

Provê os seguintes utilitários para montar e converter filmes.

  • Criar animação a partir de imagens
  • FLIC to GIFs
  • FLIC to AVI


Build Animation from Stills

Criar animação a partir de imagens

Lança o aplicativo Criar Flics/Filmes para gerar filmes AVI ou FLIC usando imagens renderizadas previamente. Além disso, possibilita AVI separados serem unidos num mesmo filme.

Se o Arquivo possuir um número como parte de seu nome, então é assumido que a sequência de arquivos deverá ser lida. Por exemplo, escolhendo um arquivo com nome Image001.TGA irá ler diretamente os arquivos nomeados Image002.TGA, Image003.TGA, etc. até o final da sequência no diretório.

Arquivos com nomes que não terminam em números são lidos como um arquivo único. Por exemplo, PICT.GIF, PICT3A.GIF.


FLIC to GIFs...

Utilitário para separar os quadros de um flime FLIC em várias imagens independentes GIF.


FLIC to AVI...

Utilitário para converter um filme FLIC num filme AVI.


Sound Effects Editor

Editor de efeitos sonoros para filmes AVI

Este programa permite vc adicionar sons e efeitos sonoros em seus filmes AVI. Vc pode coordenar sons específicos executando-os em quadros específicos com opções de mixagem. Todos os formatos WAV são suportados mas a saída AVI áudio consiste de um formato específico: 22KHz 8 bits Mono WAV.

A aplicação

Quando o programa é executado a seguinte janela aparecerá:

utils_sound1.gif (18509 bytes)

Consiste de quatro importantes componentes:

  • A barra de ferramentas
  • A janela do AVI
  • A lista de sons carregados
  • A barra de status

As operações basicas do programa são:

  • Ler um AVI (Exibirá a janela do AVI)
  • Ler um ou mais efeitos sonoros de arquivos WAV (Exibidos numa lista de sons)
  • Usar o indicador da janela do AVI para encontrar e determinar o quadro onde será adicionado um efeito sonoro.
  • Iluminar o som a ser adicionado (isso irá iniciar a execução no quadro da animação atualmente exibido na janela do AVI).
  • Qualquer mixagem cria um novo som ou sobrescreve qualquer som existente com o som iluminado.
  • Move para o próximo quadro para adicionar um efeito de som e repetir os processos até que todos os efeitos vc precisa sejam adicionados.
  • Grava a animação para um arquivo diferente do original, sente-se e curta seus filmes multimídia.

Nota importante :
Qualquer efeito sonoro adicionado a um arquivo AVI não será evidenciado até a inteira animação ser salva num arquivo. Então se vc precisar previsualizar o resultado de seu trabalho, grave a animação e abra novamente.

O detalhe da operações do programas seguem as ações dos botões na barra de ferramentas e dos comandos nos menus:

A barra de ferramentas

As ações em cada botão é descrita como segue:

utils_sound2.gif (2151 bytes)

Botão A:
Clicando neste botão aparecerá uma caixa de diálogo para os arquivos AVI, escolha um. A caixa de diálogo inclui uma capacidade de previsualizar. Se um filme lido não contém sons uma caixa de diálogo será mostrada para vc selecionar o formato da trilha de som. Podem possuir três parâmetros básicos:

  1. Frequência da amostra: Escolha entre 11kHz, 22kHz, ou 44kHz (44 kHz é qualidade de CD).
  2. Bits por amostra: 8 bits ou 16 bits
  3. Mono ou stéreo.

utils_sound3.GIF (3386 bytes)

Todos os sons numa trilha simples precisam possuir o mesmo valor para esses parâmetros. Se os sons forem de um CD vc provavelmente escolherá (44kHz, 16 bits Stereo)

Botão B:
Clicando neste botão abrirá uma caixa de diálogo. (Alguns AVI provavelmente podem não contém nenhum som). Escolha o arquivo que precisa para adicionar um som de uma lista de sons. Os sons podem ser ouvidos se desejar.

Botão C:
Grava o filme editado num arquivo. (Somente se gravados um filme editado pode ser previsualizado.)

Botão D:
Inseri um som selecionado (iluminado na lista) no quadro atual. O som será executado a partir daí, e substituirá qualquer outro existente na posição e o anterior será mostrado novamente no fim da inserção.

Botão E:
Mixa (mistura) no som selecionado (Iluminado na lista) no quadro atual. O som executará em cima do som original se existir. Ele é mixado com volume igula ao original. O som aparecerá na forma original no final da mixagem.

Botão F:
Silencia a trilha sonora.

Botão G:
Limpa a lista de sons. Remove todos os sons atuais qua podem iniciar um nova lista de sons.

Botão H:
Mostra uma caixa de diálogo com as propriedades do som selecionado na lista.

utils_sound4.GIF (3506 bytes)

No exemplo mostrado o som não foi adicionado ao filme ainda.

Botão I:
Executa o som atualmente selecionado. (Para lembrá-lo do que foi feito!)

Botão J:
Volta ou início do filme.

Botão K:
Volta um quadro.

Botão L:
Executa o filme.

Botão M:
Avança um quadro.

Botão N:
Vai para o fim do filme.

Botão O:
Faz uma cópia do vídeo para outro arquivo AVI.

Botão P:
Duplica o som do filme atual para outro arquivo selecionado na caixa de diálogo.

Botão Q:
Mostra informações sobre esse utilitário.

A barra de status

Mostra algumas instruções e informações a respeito do filme e sons selecionados:

utils_sound5.GIF (14019 bytes)

Sobre a linha de status é mostrado: [Frame 41 of 60 (2.7s)] dando informação sobre o quadro atual do filme, número do quadro e tempo. A linha de status na parte inferior da janela dá informações sobre o filme [Video] e o audio atualmente selecionado:

Para o filme:

  • Resolução,
  • Cor,
  • Número de quadros
  • Duração.

No exemplo: [640x480x24 60 Frames 4.0s] uma resolução de 640x480 pixels (VGA) 24 bit (true colour), 60 quadros de duração em 4 segundos.

Para o som selecionado:

  • O número de canais,
  • Frequência da amostra,
  • Duração
  • Bits por amostra. ID na lista de sons.

No exemplo: [2Ch 22.05kHz 1.7s 16] Uma amostra stereo gravada numa frequência de 22kHz (lembre-se que uma amostra de boa qualidade é reproduzida em 11kHz, - O humano pode ouvir até por volta de 18kHz, o telefone é em 3kHz). O som é de 1,7 segundos cada amostra é gravada em 16 bits de resolução.

O menu sistema

Comandos adicionais que duplicam uma trilha de áudio para outro arquivo, gravar a trilha de som do filme atual por exemplo é executado dentro desse menu.


Hide/Show OpenGL Camera View.

Ocultar/Exibir vista OpenGL

Vista câmera normal com visualização em malha. Vista OpenGL ocultada.

Vista OpenGL ativa. Maior consumo de memória. F11 para ativar ou clique direito na vista câmera.


Update OpenGL Script Viewer

Visualizador OpenGL

Mostra o visualizador OpenGL para renderizar o arquivo OFX atual.

Provê um método rápido para previsualizar animações com mapeamentos. O tamanho da vista pode ser aumentada arrastando o canto inferior direito da janela.

Renderiza quadro anterior
Executa animação
Renderiza próximo quadro
Para
Grava a animação renderizada OpenGL em um arquivo AVI
Grava o quadro atual como uma imagem BMP
Preferências do visualizador OpenGL
Sobre


CameraGL Menu

Menu CâmeraGL

Funções dos comandos da vista câmera OpenGL.


CameraGL Settings

Definições da CâmeraGL

Possibilita vc selecionar as propriedades da vista câmera OpenGL.

Sombreamento rígido nas faces - Renderiza o modelo sem suavização das faces.

Mapeamento rápido - Aumenta a velocidade da renderização com mapeamento.

Exibir mapeamento - Renderiza o modelo com mapeamento aplicado.

Anti-serrilhado - Renderiza com anti-serrilhado mas com aumento do tempo de cálculo.

Acelerado por Hardware (sem mapeamento) - OpenGL renderiza rapidamente se uma acelerador gráfico estiver instalado. Não renderizará mapeamento.

Luz de profundidade - Aumenta a saturação da iluminação.

Neblina - Renderiza com neblina.


Help Menu

Menu Ajuda

Mostra as ajudas do OFX.


Animator Help

Ajuda do Animador

Exibe o sistema de ajuda do modulo Animador.


General Help

Ajuda Geral

Exibe o sistema de ajuda geral do OFX.


About OpenFX..

Sobre

Exibe a versão atual do produto.


Keyframer

Q-chave

O Q-chave é um módulo interno que controla as linhas do tempo e quadros chaves de todos os Atores que podem ser visualizados e editados.

O módulo é exibido através do menu Visualizar > Exibir Q-chave ou pressionando a tecla K. Pode também ser mostrado como uma janela acessando o menu Visualizar > Q-chave flutuante/docado ou pressionando Crtl K.


Keyframer Layout

Layout do Q-chave

Na janela do Q-chaves, o tempo caminha horizontalmente da esquerda para a direita. Cada ator possue quatro linhas do tempo Avatar, Posição (Movimento), Rotação, Tamanho (eescala), de cima para baixo. São representados nas cores azul, amarelo, verde, vermelho respectivamente.

Os quadros chaves são pontos quadros em suas respectivas linhas e cores. No modo Janela possui um simples menu Editar onde os atores podem ser modificados, a barra de status mostra o alcance dos quadros e o quadro indicado (no canto inferior direito). Os quadros-chaves podem ser arrastados com o mouse e normalmente são criados quando vc altera alguma característica no Animador para a cena.


Channels

Linhas do tempo

São usadas para controlar as atividades do Ator na animação. Cada ator possui 4 linhas do tempo que são: Avatar, Posição, Rotação, e Tamanho. As linhas Horizontais que as representam são: Azul, Amarelo, Verde e Vermelho respectivamente.

Uma linha do tempo possui um número de quadros e quadros-chaves associados a elas.


Add a Timeline

Adicionar uma linha do tempo

Para criar uma linha do tempo no Q-chave, mova o cursor na linha do tempo até o quadro desejado e clique. Uma caixa de diálogo aparecerá, com as opções apropriadas para a linha do tempo.


Edit a Channel

Editar uma linha do tempo

Clique na linha do tempo para dividi-la em duas e crie um novo quadro-chave no quadro indicado. Duplo clique no indicador no Q-chave para chamar a caixa de diálogo correspondente.

Os indicadores nas linhas do tempo podem ser arrastados para ajustes.


Costume Channel

Linha do tempo avatar

Ela determina a aparência do Ator, i.e, qual avatar o ator usará.

Nota: Um ator pode existir sem um avatar, mas ele será invisível. Este é um caminho para fazer atores desaparecerem durante a animação, simplesmente apague a linha do tempo avatar nos quadros apropriados.

Exceto os atores Câmera e Alvo, que não possuem avatar, as definições são agrupadas na caixa de diálogo que aparecerá quando um linha do tempo é criada. Essa caixa mostra a extensão da linha do tempo, e outras configurações dependendo do tipo de ator.

Duplo clique no Q-chave no indicador no fim de uma linha do tempo do avatar exibe uma caixa de diálogo com botões apagar, cortar, copiar e editar.

Editar - Altera as definições dependendo do tipo de ator.

Cancelar - Sai da caixa de diálogo.

Apagar - Apaga a linha do tempo removendo-a do Q-chave.

Cortar - Corta um avatar da linha do tempo.

Copiar - Copia uma avatar e sua linha do tempo com as mesmas definições.


Model Costume Channel

Linha do tempo avatar

Permite vc ligar uma morfose, definir os quadros onde o modelo aparecerá, especificar o modelo a ser usado, e os Efeitos especiais.

Morfose - permite um modelo transformar-se gradualmente em outro.

Para morfosear um modelo deve haver pelo menos 2 linhas do tempo avatar. Cada linha do tempo está associada a um modelo (arquivo MFX). Os dois modelos devem possuir o mesmo número de vértices, arestas e faces.

Malha | se ticada, o renderizador irá renderizar os atores em malha. A malha é renderizada com anti-serrilhado. Note que o atro se apresentará como um sólido e lançará uma sombra também sólida e aparecerá sólido em qualquer reflexão Raytrace.
Sombra própria | Se ticada (por padrão), o ator lançará sombras em si mesmo quando o Raytrace estiver ativado. Será ignorado se o Raytrace estiver desligado.
Lançar sombras | Se ticada (por padrão), o ator lancará sombras. Em modos não Raytrace somente luzes spot lançarão sombras, exceto nos casos especias ondo o Ator tem atribuido pseudo sombra definido pelo Designer.
Exibir sombras | Se ticada (por padrão), o ator mostra as sombras (em si mesmo) de outros atores. Note novamente que somente luzes spot exibem sombras nos atores, exceto se o modo Raytrace for ligado.


Camera Costume Channel

Linha do tempo câmera avatar

Está automaticamente presente em todos os quadros e não pode ser alterada.


Target Costume Channel

Linha do tempo avatar alvo

Alvos são usados para apontar a câmera e as luzes spots para uma específica localização.

Alvos podem seguir caminhos ou outros Atores. Alvos ajudam também para alinhar sequências de ação.

Não há outros parâmetros para editar alvos.


Light Costume Channel

Linha do tempo luz

As definições da luz permite vc especificar o tipo de luz usada.

Cor da luz - Specifica a cor e brilho de uma luz. Reduzindo a luminiscência da cor da luz pode reduzir o seu brilho.

Normal - Luz ilumina uniformemente em todas a direções.

Sem sombra - Funciona como uma luz norma, mas não lança sombras.

Somente sombra - Essa luz é usada somente para gerar sombras.

Luz spot - Esta luz ilumina numa direção determinada por um cone. A direção é especificada adicionando rotação e eescala. Luzes spot realistica consomem muita memória.

Objeto referencial - Esse tipo de luz não ilumina ou lança sombras. É usada para determinar o local de Pós-processos como reflexos de lentes, auréolas, etc.

Atenuação - Ativa a Iluminação de profundidade.


Path Costume Channel

Linha do tempo avatar do caminho

Os avatares dos Atores caminhos podem ser editados usando a ferramenta selecionador de nós e Velocidade das curvas.


Sky Settings Dialog

Definições da atmosfera

O tipo de atmosfera e a iluminação ambiente podem ser especificadas na caixa de diálogo.

Tipos de atmosferas

Plana - Usa uma cor única para o plano.

Degradê - Um degradê é aplicado a partir do horizonte até o zênite (ponto no céu exatamente acima do observador).

Mapa ambiente ... - Um arquivo imagem pode ser usado para representar a atmosfera. Pode-se imaginá-lo como um pintura na parte interna de uma esfera envolvendo os atores. O mapa é usado quatro vezes em uma revolução completa, e duas vezes entre o horizonte e o zênite. Em outras palavras, se a câmera rotacionar 360 graus vc verá 4 cópias do mapeamento. Dica: Use um mapeamento que é concatenável em todas as direções, O uso desses mapeamentos dão uma boa sensação de movimento quando a câmera está sobrevoando um objeto específico.

Cenário... - Use uma imagem como plano de fundo (fixo). Se a imagem não possuir o mesmo tamanho da animação será escalonada apropriadamente. Nota: Usando mais que uma linha do tempo no avatar do ator atmosfera poderá mudá-lo de cor durante a animação. Um pôr ou nascer do sol pode ser simulado dessa formao.

Cenário ambiente ... - Use uma série de imagens (Map001.gif, Map002.gif, Map003.gif...) como um plano de fundo animado. Se o valor 1 for especificado na caixa primeiro quadro da sequência, então o Map001.gif será o plano de fundo do quadro 1, Map002.gif será o plano de fundo do quadro 2, Map003.gif será o plano de fundo do quadro 3, etc. Se um valor de 2 for aplicado ao primeiro quadro da sequência então o Map001.gif será plano de fundo do quadro 1, Map003.gif será o plano de fundo do quadro 2, Map005.gif será o plano de fundo do quadro 3, etc.

Botão visualizar - Exibe a imagem especificada no ambiente ou cenário.

Iluminação ambiente

Ilumina os atores a partir de todas as direções ao mesmo tempo. Sendo assim uma imagem irá aparecer mais brilhante e com contraste com valores mais baixos e com menos contraste se o valor for alto. Um valor máximo aceitável é 50%.

É possível definir ainda a iluminação separadamente para o solo e os modelos. Por isso existem dois campos, um para cada um.


Ground Settings

Definições do solo

São inseridas na caixa de diálogo abaixo:

A cor primária do solo é definida clicando a cor do solo a direita da caixa de diálogo e escolhendo da paleta de cores que se abrirá. A Cor da textura é usada a segunda cor usada por extensões de textura.

Reflexo do solo- O solo pode ser parcialmente refletivo, o valor máximo permitido é 60%. A atmosfera não é refletida, Mas outros atores são. Essa reflexão não exige Raytrace, mas exige um pouco mais de memória.

Tipos de solo

Plano - Uma simples cor é aplicada ao solo.

Textura - Escolha o tipo de textura a partir da lista em Textura do solo. Há várias texturas com ondas que simulam uma superfície de liquido em movimento. Quando o ator solo éstá selecionado, uma retângulo é desenhado na vista superior. O retângulo representa a unidade básica de repetição da textura. Vc pode escalonar, rotacionar ou mover essa unidade adicionando também movimento.A linha vertical na vista Anterior e laterais é usada para indicar o relevo ou altura de textura.

Mapeamento do solo - Vc pode usar imagens para mapear o solo dando também movimentos a ele. Quando um ator solo está selecionado, um retãngulo amarelo na vista superior representa o tamanho, posição e orientação do mapeamento. A linha vertical na vista Anterior e laterais é usada para indicar o relevo ou altura de textura e não é aplicado ao mapeamento

Única - Uma única imagem é posicionada no retângulo do mapeamento.

Repetir - A imagem é repetida em toda a extensão do solo.

Mosaico - A imagem é repetida sendo espelhada no seus lados para criar uma ilusão de que seja contínua.

Botão visualizar - Visualiza a imagem específicada para o mapeamento.


Image Effect Costume Channel

Linha do tempo avatar do efeito

Permite vc especificar quais quadros serão afetados pelo tipo de pós-processo usado.


Robot Costume Channel

Linha do tempo avatar do robô

Robôs são editados usando Pôse do robô.


CSG Object Costume Channel

Linha do tempo do ator CSG

Edita o tipo de AtorCSG a partir de uma caixa de diálogo.

Atores CSG podem ser aditivos ou subtrativos, Atores CSG com tubo e disco não possuem volume para fazer uma subtração. A opção adicionar é automaticamente selecionada pelos volumes CSGs. Se vc intencionar realizar um corte em outro CSG, então clique o botão Subtrair, caso contrário clique o botão adicionar.


Movement Channel

Linha do tempo posição

A linha do tempo posição no Q-chave controla onde e como um modelo irá mover entre quadros-chaves.

Todas as definições estão numa única caixa de diálogo. Ela mostra a extensão da linha do tempo, as coordenadas e o Tipo de movimento.

Apagar - apaga a linha do tempo.

Cortar - apaga a linha do tempo atual e retorna todas as posições anteriores.

Copiar - copia as características do movimento para outro ator.


Movement Types

Tipos de movimentos

Há 6 tipos de movimentos para um Ator.

Interpolar - A posição do Ator é interpolada linearmente entre o primeiro quadro-chave e os subsequentes. Por exemplo, se o ator possuir um movimento nos quadros 1-1 e 2-10 e ele está nas coordenadas 0,0,0 no quadro 1 e nas coordenadas 10,10,10 no quadro 10 então no quadro 5 ele estará na coordenada 5,5,0.

Curva natural- A posição do ator é interpolada numa curva ancorada nos quadros-chaves removendo o efeito de cantos agudos. Provendo assim um movimento mais natural com aceleração e desaceleração suaves.

Os próximos tipos requerem que um ator persiga outro. Clique no botão Seguir para definir o ator que será seguido.

Seguir - O ator irá seguir outro ator num caminho. Dica: faça uma luz seguir a câmera. Isso irá dar uma boa iluminação aos atores visíveis.

Seguir com balanço - O Balanço é definido no modelo que o ator está usando como avatar. O balanço é indicado para cruz vermelha no modelo visível no Designer (ponto perseguidor).

Seguir no caminho - segue um ator num caminho considerando seu balanço. Por exemplo, uma locomotiva segue um caminho, o primeiro vagão segue a locomotiva e assim sucessivamente.

Seguir amarrado- Segue um ator amarrado em um dos eixos de coordenadas. As outras coordenadas está livres para mover.


Tween Movement

Movimento interpolativo

A posição do Ator é interpolada linearmente entre o primeiro quadro-chave e os subsequentes.

Por exemplo, se o ator for movido nos quadros 1-1 e 2-10 e ele está no (0,0,0) no quadro 1 e no (10,10,0) no quadro 10 então estará no (5,5,0) no quadro 5. Deixe o programa calcular os intervalos entre os quadros-chaves.

Uma trilha será visível na vista quando o modo interpolativo estiver ativo.

Nota: O linha do tempo posição padrão é definida para Interpolação.


Spline Tween Movement

Movimento interpolativo suave

A posição do Ator é interpolada (cálculo automático do movimento entre dois pontos) em uma curva ancorada em quadros-chaves removendo o efeito de cantos retos. Isso promoverá um movimento mais natural com aceleração e desaceleração.

Uma trilha curva é visível na vista quando modo interpolativo estiver ativo.

Nota: o movimento padrão definido é interpolativo, portanto interpolativo suave precisa ser definido na linha do tempo posição do ator selecionado para gerar um caminho curvo.


Follow Movement

Seguir

Ator selecionado irá seguir outro ator.

O ator a ser perseguido é especificado clicando o botão selecionar na caixa seguir na linha do tempo posição. Quando um ator for selecionado o botão para seguir precisa estar ativado.

Dica: Crie uma luz seguindo uma câmera.


Follow with Offset

Seguir com balanço

Segue um Ator usando seu balanço.

O balanço é especificado no modelo que o ator está usando como seu avatar. O Balanço do modelo é indicado pela cruz vermelha (ponto perseguidor) que é visível no designer. Note que caminhos, alvos e luzes não possuem um balanço para seguir.

O ator a ser perseguido é especificado clicando o botão selecionar na caixa seguir na linha do tempo posição. Quando um ator for selecionado o botão para seguir precisa estar ativado.


Follow On a Path

Seguir no caminho

Segue um Ator num caminho.

Dessa forma uma locomotiva pode seguir um caminho e os vagões a acompanharão. A loco segue um caminho, o primeiro vagão segue a loco, o segundo vagão segue o primeiro, e assim sucessivamente.

Note que caminhos, alvos e luzes não possuem um meio para seguir.

O ator a ser perseguido é especificado clicando o botão selecionar na caixa seguir na linha do tempo posição. Quando um ator for selecionado o botão para seguir precisa estar ativado.


Follow Locked

seguir amarrado

Segue um ator amarrado em uma ou mais das três coordenadas. As coordenadas desamarradas estão livres para mover.

O ator a ser perseguido é especificado clicando o botão selecionar na caixa seguir na linha do tempo posição. Quando um ator for selecionado o botão para seguir precisa estar ativado.


Rotation Channel

Linha do tempo rotação

É a linha verde no Q-chave e controla a rotação de um Ator de acordo com os quadros-chaves.

A caixa de diálogo mostra a extensão da linha do tempo, o alinhamento em graus nos 3 eixos do ator, e o tipo de rotação.

Apagar - apaga a linha do tempo rotação.

Cortar - apaga a linha do tempo corrente.

Copiar - copia as características de rotação para outro ator.


Rotation Types

Tipos de rotação

Interpolar - A rotação do ator é interpolado entre o primeiro quadro-chave e o último. Em outras palavras, marque os quadros-chaves e o programa se encarregará de calcular o intervalo.

Interpolação suave - Cria uma rotação mais natural com aceleração e desaceleração.

Os próximos tipos necessitam que o ator esteja alinhado, acompanhando, imitando a rotação de outro ator.

Alinhar no caminho - Se um ator está seguindo um caminho, então defina sua rotação no caminho.

Acompanhar - O ator é forçado a acompanhar um outro ator.

Imitar - Dá a este ator o mesmo alinhamento do ator alvo.

Rotação interna - Há alguns tipos especiais de rotações que são difíceis de fazer manualmente. Os botões na caixa de rotação interna possibilitam uma rápida forma de especificar movimentos internos, isto é, relativo ao Ator. Um exemplo disso é as lâminas do rotor de um helicóptero. A direção do ator é especificada nos quadros chaves, enquanto que a rotação interna é determinada por esses controladores.


Internal Rotation Types

Tipos de Rotação interna

Há alguns tipos especiais de rotações que são difíceis de fazer manualmente. Os botões na caixa de rotação interna possibilitam uma rápida forma de especificar movimentos internos, isto é, relativo ao Ator. Um exemplo disso é as lâminas do rotor de um helicóptero. A direção do ator é especificada nos quadros chaves, enquanto que a rotação interna é determinada por esses controladores.

Nenhum - nenhuma rotação interna.

Eixo vertical - Ator rotacionado internamente através do eixo vértical (Z na vista superior) do centro do ator.

Eixo lateral - Ator é rotacionado internamente através do seu eixo lateral (X na vista lateral).

Eixo Frontal - Ator é rotacionado internamente através do seu eixo frontal (Y na vista Anterior).

Sentido horário - Ator é rotacionado na direção no eixo especificado vertical, lateral ou frontal.

Sentido anti-horário - Ator é rotacionado na direção no eixo especificado vertical, lateral ou frontal.


Scale Channel

Linha do tempo escala

Controla como um Ator mudará de tamanho numa animação.

Os valores devem ser inseridos na caixa de diálogo de acordo com a unidade padrão no momento.

Escalonamento suave - Suaviza o efeito de eescala.

Apagar - apaga a linha do tempo.

Reiniciar - define todos os valores da eescala para a unidade.

Armazenar - guarda o valor da eescala na memória.

Restaurar - lê o valor guardado na memória.

Copiar - copia os valores da eescala para outro modelo.


Model Scale Channel

Linha do tempo tamanho do modelo

Controla como um Modelo selecionado irá alterar de tamanho entre quadros-chaves.

Os valores devem ser inseridos na caixa de diálogo de acordo com a unidade padrão no momento.

Escalonamento suave - Suaviza o efeito de eescala.

Apagar - apaga a linha do tempo.

Reiniciar - define todos os valores da eescala para a unidade.

Armazenar - guarda o valor da eescala na memória.

Restaurar - lê o valor guardado na memória.

Copiar - copia os valores da eescala para outro modelo.


Camera Scale Channel

Definições da câmera

Altera as propriedades de lentes da câmera e outros parâmetros.

Vc pode especificar o campo de visão da câmera em graus. Um raio de 1.0 criará uma imagem de proporção verdadeira (se o pixel for quadrado)


Target Scale Channel

Linha do tempo escala do alvo

O ator alvo não pode ser escalonado.


Light Scale Channel

Escalonamento da luz

Os parâmetros da luz controlam como o cone da luz spot selecionada mudará seu tamanho.

Ângulo do cone - Define o ângulo principal da abertura do spot. O valor máximo permitido é 179.

Ângulo de suavização dos cantos - Define a suavidade da borda do limite da luz. Um valor em torno de 5 é o padrão produzindo uma sombra suave bem realistica.

Alcance da atenuação - Define a distância onde a intensidade da luz é reduzida a zero. O círculo em volta da luz (visível somente quando ticado a opção atenuação nas propriedades da luz) determina o limite da iluminação.


Path Scale Channel

linha do tempo eescala do caminho

O tamanho do caminho não pode ser escalonado.


Sky Scale Channel

Linha do tempo tamanho da atmosfera

O ator atmosfera não pode ser redimensionado e não possui um linha do tempo escala.

Note que também não possue linha do tempo rotação e posição.


Ground Scale Channel

Linha do tempo eescala do solo

Controla o tamanho e aparência das texturas além da rotação e tamanho de qualquer mapeamento aplicado ao solo.

A caixa de diálogo é em unidades atuais do Animador.

Escalonamento suave - Calcula a interpolação entre os quadros-chaves para realizar um efeito mais suave durante a animação do escalonamento.

Apagar apaga a linha do tempo.

Reiniciar define todas as eescalas para a unidade.

Armazenar copia os valores da eescala para uma memória temporária para uso posterior.

Restaurar Carrega os valores da eescala de acordo com os valores previamente armazenados.

Copiar copia a características da eescala para outro ator CSG.


Image Effect Scale Channel

Linha do tempo tamanho do efeito

O ator efeito não pode ser escalonado, e nem possui linhas do tempo posição ou rotação.


Robot Scale Channel

Linha do tempo eescala do robô

É a mesma coisa que a linha do tempo eescala do ator.


CSG Object Scale Channel

Linha do tempo eescala do ator CSG

Controla o tamanho do ator CSG

Uma caixa de diálogo aparece quando uma linha do tempo é criada ou editada.

Escalonamento suave - Calcula a interpolação entre os quadros-chaves para realizar um efeito mais suave durante a animação do escalonamento.

Apagar apaga a linha do tempo.

Reiniciar define todas as eescalas para a unidade.

Armazenar copia os valores da eescala para uma memória temporária para uso posterior.

Restaurar Carrega os valores da eescala de acordo com os valores previamente armazenados.

Copiar copia a características da eescala para outro ator CSG.


Pose Robot

Pôse Robô

Permite posicionar um ator Robô . O movimento do robô é animado especificando uma posê determinada para cada quadro-chave. A sequência animada irá gerar um movimento suave do personagem.

Para colocar uma pôse ao robô, selecione o ator robô e escolha a ferramenta selecionador de vértices (tecla V). Quando o modo de edição do robô entrar, as janelas hierarquia do Robô e vista robo irão aparecer.

Uma ligação selecionada é pivotada clicando em uma das vistas e arrastando o mouse para a esquerda ou direita. A ligação selecionada estará iluminada no esqueleto e na hierarquia do robô.

Selecione uma ligação:
 | 1) | Clicando em uma ligação do robô na vista.
 | 2) | Clicando num ícone na hierarquia do robô.

A hierarquia do robô provê uma árvore dos elementos e uma caixa de ferramenta para manipulação.

Comandos
 | Ler uma pôse de uma arquivo.
 | Grava uma pôse num arquivo.
 | Reinicia a pôse atual conforme inserida no ator robô.
 | Reinicia uma ligação selecionada.
 | Copia uma pôse do último quadro-chave.
 | Zoom + na ligação selecionada ou seu ponto pivô.
 | Zoom na posição da ligação ou ponto pivô selecionado.
 | Permite o esqueleto ser desenhado sobrexposto na vista robô.
 | Desenha os cubos limitados transparentes para mostrar o esqueleto interno.

Eixos do pivô - Local nas ligações selecionadas.
 | Pivô sobre o eixo a partir da ligação parente até seu parente.
 | Pivô no ângulo direito sobre o eixo a partir da ligação parente
 | Pivô no ângulo direito até o por cima do segundo sobre o eixo a partir da ligação parente.
 | Vértices pivô filho em volta da ligação selecionada.
Eixos do pivô - Globais. Esses eixos são os mesmos que estão disponíveis no Designer e sua orientação pode ser definida quando o robô é construido.
 | Pivô sobre um eixo desde a parte posterior até a anterior do robô.
 | Pivô sobre um eixo desde a parte direita até a esquerda do robô.
 | Pivô sobre um eixo vertical através do robô

A vista robô provê uma perspectiva de cada ator robô exibindo ligações selecionadas.

A vista robô sempre aparecerá centrada na robô selecionado e mostrará sua pôse.


Post Processor FireballPlugin

Bola de Fogo

Essa extensão gera bolas de fogo fractais e explosões.

Como essa extensão trabalho com elementos animados, é melhor usada como um ator de efeito (FX).

Essa extensão é controlada pela caixa de diálogo abaixo:

fireball1.gif (47745 bytes)

Igual aos efeitos Auréola e Reflexos de lentes a Bola de Fogo é amarrada a uma luz. Ela pode ser amarrada a uma luz normal associando-a com um cubo limitado. Agora éssa é a restrição principal:

A luz onde está amarrada a bola de fogo precisa ter sua origem atenuada

Se vc tentar usar uma Bola de fogo com uma luz não atenuada éla não funcionará. A razão de usar uma luz com atenuação é para indicar ao Animador que a esfera que define a atenuação define a intensidade da bola de fogo ou explosão. O efeito usa essa esfera como um container para confinar a bola de fogo no seu interior.

Veja um exemplo do resultado espetacular desse efeito!

XFXfireball2ps.jpg (7203 bytes)

Clique aqui para ver uma imagem maior

Controlando o efeito:

  • Chamas
    Quando esse botão estiver ticado a aparência será como a imagem da direita.
    temp.gif (12904 bytes) temp1.gif (21608 bytes)
  • Explosão
    A explosão irá gerar bolas de fogo que irão aparecer e dispersar em fumaça no final da animação.

Definições da luz
O efeito pode ser aplicado a todas as luzes na cena ou a uma luz especificada.

Cores
Existe 3 definições. A escuridão é usada para a cor da fumaça, a do centro para o coração da bola de fogo e a externa para as extremidades da chama.

Suavização da granulação
Veja no esquema abaixo o que a suavização pode fazer. Coloque os valores na caixa para o efeito desejado.

temp.gif (48513 bytes)

Densidade
Use para definir o brilho, veja a ilustração para ver o que certos valores podem causar.

temp.gif (35054 bytes)

Regularidade
A regularidade (Padrão 0.2) determina como a explosão vai aparecer. Um valor de 2.0 é próximo a uma perfeita esfera (ou uma estrela)

temp.gif (33016 bytes)

Alcance vertical
Use em conjunto com uma chama para simular uma fogueira, por exemplo. A imagem abaixo usa um valor de 3.

temp2.gif (8497 bytes)

Expansão
Quando este valor é o padrão então o tamanho da esfera envolverá a bola de fogo. Se vc deseja que a bola de fogo ocupe um espaço maior ou menor, altere esse valo.

Amostras
Controlam a qualidade da integração fractal, um valor alto aplica mais detalhes na bola de fogo, mas aumenta o tempo de cálculo. Um valor abaixo de 4 pode dar uma boa aparência a bola de fogo.


Postprocessor Atmospherics

Pós-processo Luz-Volumétrica

Cria um efeito volumétrico no cone da luz spot. Ele é controlado através da caixa de diáloga abaixo

Aviso: calcular esse efeito é muito demorado, portanto escolha cuidadosamente as opções aqui

SFXplugAtmosXX1.GIF (45198 bytes)

A primeira coisa a considerar é que há dois tipos de efeitos atmosféricos cobertos na caixa de diálogo:

  1. Uma simulação detalhada do efeito volumétrico envolvendo um tempo de calculo alto e ajustes finos nos parâmetros que requerem experimentação para que vc consiga o resultado desejado, esses parâmetros são Amostras, Neblina superdensa, Sombra extra-forte e Atenuação máxima.
  2. O segundo tipo é uma aproximação instantânea que não envolve muito detalhamento e cálculos. Para usá-los habilite a caixa Usar efeitos atmosféricos e escolha o tipo de efeito (As outras opções não afetarão esses efeitos).

Os efeitos trabalham em conexão com as luzes do tipo Spot, vc pode especificar qual luz será afetada pelo efeito.

Tipo de efeitos volumétricos
Vamos comparar os efeitos com uma simples luz spot sobre um objeto como representado abaixo:

SFXplugAtmosXX3.gif (13723 bytes)

Agora vamos adicionar o efeito chamado "Raios de luz" que apresentará um resultado semelhante a este: (lembre-se de ticar a caixa de efeitos volumétricos)

SFXplugAtmosXX4.gif (17132 bytes)

Esse tipo de luz representaria bem uma atmosfera num dia frio com as luzes entre as árvores ou imagens subaquáticas.

Agora vamos aplicar o efeito "Vento" :

SFXplugAtmosXX5.gif (17368 bytes)

E agora vamos tentar o "Poeira":

SFXplugAtmosXX6.gif (25039 bytes)

Por fim o efeito "Fumaça" :

SFXplugAtmosXX7.gif (17330 bytes)

'Integração total da luz volumétrica'

Para obter um tipo de luz volumétrica super real teremos que usar o Raytrace. Claro que usando esse recurso o tempo de renderização aumentará consideravelmente. Quanto maior o número de amostras maior o tempo do Render.

Outro controle é a aparencia da neblina. Basicamente são Neblina superdensa e Sombra extra-forte.

Para vermos como as amostras trabalham, analisemos os exemplos abaixo:

Uma luz sem efeito aplicado:

SFXplugAtmosXXfull0.gif (8305 bytes)

Renderizando com 32 amostras e os valores para: (Neblina superdensa)=0.0 (Sombra extra-forte)=0.0 (Atenuação Máx.) temos:

SFXplugAtmosXXfull1.gif (17293 bytes)

Reduzindo o valor da Atenuação máxima para 0.25 reduz a densidade da neblina assim:

SFXplugAtmosXX9.gif (15670 bytes)

Usando (Sombra extra-forter)=1.0 teremos: (Para um cena mais natural o valor apropriado é 0.0:

SFXplugAtmosXXfull2.gif (17729 bytes)

Por fim usando (Neblina superdensa)=1.5

SFXplugAtmosXXfull3.gif (12077 bytes)

Veja esses outros exemplos:

No exemplo abaixo 16 amostras são usadas com Neblina superdensa a 3.0:

SFXplugAtmosXXex1.gif (32682 bytes)

SFXplugAtmosXXex2.gif (31154 bytes) SFXplugAtmosXXex3.gif (31471 bytes)

No exemplo abaixo (atmos_full_ex3.stg) um pós-processo neblina é combinado com a luz volumétrica. Note que vc pode ver a luz atravessar por um dos buracos do objeto (a partir do quadro 3) o rastro é renderizado na cor da neblina.

No último exemplo (Atmos_full_ex4.stg) um intenso efeito de luz atravessa um objeto com valores de Neblina superdensa 1.0 reduzindo para uma atenuação máxima de 0.5.

SFXplugAtmosXXex4.gif (47471 bytes) SFXplugAtmosXXex5.gif (32447 bytes)

Comentários:

  1. Quanto mais áreas da tela forem cobertas com a luz volumétrica mais demorado será a renderização. Veja no exemplo abaixo que a luz está um pouca abaixo da aeronave vindo em direção a câmera o que levará a um tempo muito grande de renderização:
    SFXplugAtmosXXA.gif (38398 bytes)
  2. Faça experimentos usando resoluções mais baixas. Veja os exemplos que acompanham o progama.
  3. A extensão de luz volumétrica ésta na subpasta Postprocess sob os nomes ATMOS.XFX e ATMOS.DLL.
  4. Os 'Efeitos volumétricos' são mais velozes, use-os sempre quando for apropriado.


Renderer Help

Ajuda do Renderizador

O Renderizador é o módulo que cria as images sequênciais para montar a animação.

Render consome tempo de processamento de acordo com as opções determinadas na caixa do Render.


Closed Path

Caminho fechado

Um caminho fechado tem loops e precisa ter no mínimo três nós.

Caminho fechado


Depth Cued Lighting

Iluminação de profundidade

Possibilita luzes normais e "spots" serem configuradas para que a força de sua luminosidade seja dependente de suas distâncias limites.

Essa opção é muito interessante para usuários avançados terem um fino controle da iluminação. Note que é muito fácil gerar uma imagem negra se essas configurações não forem definidas corretamente. Sendo assim, essa opção é por padrão desligada.

Aqui há dois componentes para criar uma iluminação de profundidade:

1) | Ligando a caixa atenuação na caixa de diálogo definições da Luz. Se a atenuação estiver ligada, a luz é exibida com um círculo pontilhado envolvendo-a. Esse círculo determina o alcance da iluminação da luz. Por padrão esse raio é de 10 unidades. O raio pode ser definido manualmente na eescala da luz ou escolhendo os "Parâmetros da luz" através menu luz.
2) | Fator de atenuação da luz - Aumenta o parâmetro linear fazendo a luz decair para um valor menor na localização do círculo pontilhado. Por exemplo, valor de atenuação de: Constante=1.0, Linear=1.0, e Quadrática=2.0 produz uma luz com limite muito limitado.


Direction Tab Page

Direção

Controla a rotação de um ator num Caminho.

A direção do ator para cada quadro-chave de rotação é indicado com uma flecha. Clique nos botões para escolher qual eixo de rotação será editado. Somente The direction the Actor would be pointing at each Rotation keyframe is indicated with an arrow. Click buttons in the dialog to choose which rotation axis is edited. Only Tween or Accelerated rotation timeline types can have a their rotations controlled through this mode. Any other rotation timeline types cannot enter Edit Direction mode. The shape of the Track depends on the movement timeline for the selected Actor.

Direct - The Direction the Actor is pointing at keyframes on the track is adjusted by clicking on a keyframe arrow to pick it up. Move the mouse and the direction arrow will pivot Round, Up/Down or Bank left/right. Click again to release your hold on the arrow. If a non-keyframe frame indicator is selected you will be prompted with the option to make it a keyframe.

Time Shift - Adjusts which frames are the keyframes in the selected Actor's rotation timeline. Click on the keyframe arrow to pick it up. Move the mouse left or right to shift the keyframe to an earlier or later frame. Click again to set the arrow down. This is like slipping beads up or down the string running through them.

Delete - Demotes a Keyframe to a normal frame.

Tension - This only applies if the Rotation timeline is of Accelerated type. If it is then in this mode the direction arrow can be made to "behave less elastically". Click on the keyframe arrow to pick it up. Move the mouse left or right to adjust the tension in the spline "elasticity in the arrow directions". Click again to set the arrow back down. This is like tightening or loosening the string running through the selected bead.


Ground Shader Types

Tipos de textura de solo

A cor primária do solo é definida clicando na Cor básica do solo e escolhendo através da caixa de diálogo. A cor da textura é usada para especificar uma cor secundária necessária para as texturas.

Colorir - Exatamente o mesmo que cor do plano do solo.

xadrez - O tradicional xadrez (do tabuleiro). Duas cores são especificadas. O retângulo da eescala controla o tamanho dos quadrados.

Grade - Uma grade linear. Duas cores são especificadas. O retângulo da eescala controla o tamanho da grade.

Listras - Muito similar a grade.

Pontos - Uma textura com pontos circulare.Duas cores são especificadas. O retângulo da eescala no eixo X controla o tamanho do espaçamento entre os pontos, no eixo Y controla o raio dos pontos, no eixo Z não é usado.

Cruzes - Cria cruzes regulares no plano. Duas cores são especificadas.O retângulo da eescala no eixo X controla o tamanho do espaçamento entre as cruzes, no eixo Y controla o raio dos pontos, no eixo Z não é usado.

Tijolo - Uma textura de tijolo regular. O retângulo da eescala no eixo X controla o tamanho horizontal do tijolo, no eixo Y controla o tamanho vertical do tijolo.

Áspero - Essa é uma textura de relevo. Pode ser usada para simular areia, planetas alienígenas, etc. Uma cor é necessária especificar. Os eixos (X) e (Y) do retângulo da eescala controlam a densidade do relevo. O eixo Z controla a altura do relevo.

Texturas de Ondas - Essas textura são animadas. Elas possuem um loop suave em intervalos de 20 quadros. Lembre-se que a posição da luz é muito importante para ter um efeito magnífico.

Veja os tipos que vc pode usar:

Onda O eixo Y do retângulo da eescala controla o intervalo das ondas e o eixo Z a altura das mesmas.

Onda Circular possuem várias origens, aproximadamente 10. São colocadas em vários pontos dentro do retângulo da eescala. O eixo Y controla o intervalo das ondas o Z o tamanho das ondas, o X como as ondas são dispersadas da origem.

Oceano é idêntica a textura Onda Circular, mas o Oceano possui um algorítmo diferente. Em vez de produzir ondas circulares, produz ondas normais, 7 origens aproximadamente. E são colocadas randomicamente.


Loaded Path

Ler caminho

Abre um caminho que foi gravado como um arquivo .PTH, criado no designer anteriormente.

Alguns exemplos de caminhos gravados: Circular.pth, Elliptic.pth, Helix.pth, Parabola.pth, and Spiral.pth.


Open Path

Caminho Aberto

Possui pontos inicial e final distintos. Precisa ter pelo menos 2 nós.

Caminho aberto

Note que Selecionador de nós pode ser usada para modificar a forma e o número de pontos no caminho.


Phong Smoothing

Suavização

Esse é um procedimento que remove a aparência facetada de superfícies curvas de modelos.

O diagrama abaixo mostra um cilindro suavizado e um facetado.

Quando condições de iluminação são aplicadas a um objeto facetado, as sombras resultarão em algo como:

Isso ocorre porque superfícies de triângulos são planas. Quando aplicamos a suavização, os cantos das faces, principalmente alguns daquelas que formas ângulos obtusos, o sombreamento ocorrerá de forma homogênea para aproximar quanto for possível a uma superficie curva.

compare abaixo os resultados: com um cilindro real e um cilindro suavizado.

Note que os cantos que formar um ângulo igual ou menor que noventa graus não são suavizados.

If possible, smoothing should only be applied to faces with angles of 60 degrees or less (to adjacent faces). You must be quite selective in which faces you choose to apply smoothing too.

A few more words need to be said about the problem that was hinted at earlier with regard to the cylinder.

There will be no problem (with angles) in smoothing the curved surface of the cylinder provided 6 or more edges around a circular end were used (12 triangular faces on the curved surface). However it is desired to retain the crease between the top surface and the side, and of course at the bottom as well.

To achieve this smoothing should be applied to the faces on the curved surface only.

For a cylinder such as the one shown below this can be done by selecting all the vertices that make up the cylinder and then setting smoothing to OFF. Then, by using the Selector (in a window which show the circular section), the vertices at the center of the top and bottom surfaces are selected. Finally by clicking on the Select Swap icon the appropriate vertices are selected. Smoothing is activated for faces in the Designer's Attributes dialog.

Quando deseja suavizar várias superficies que formam angulos proibidos separe a superfície desejada da outra criando um chanfro entre elas e então aplique a suavização.

Canto comum

Chanfro (Um canto para cada superfície)

Para aplicar a suavização a faces específicas, selecione-as somente elas.


Track

Trilha

Uma trilha é um caminho implícito que um Ator segue durante a animação.

Trilha interpolada curva

Um trilha aparece como um serie de segmentos de reta (interpolado) ou curvas (interpolado suave) Com pequenos quadrados ao longo dela onde cada peça indica onde o ator irá agir em cada quadro da animação. A aparência é igual a um colar, onde cada conta é um quadro e cada conta grande é um quadro-chave (em púrpura).


Track Tab Page

Interpolação

Controla o movimento de um ator numa trilha

Mover - A posição do ator nos quadros-chaves na trilha é alterada clicando no indicador do quadro-chave. Mova o mouse e o quadro-chave seguirá o mouse até a posição desejada. Clique novamente para soltar o indicador. Se não houver nenhum indicador vc poderá criar um na caixa de diálogo que aparecerá.

Alternar tempo - Ajusta quadros que são quadros-chaves na linha do tempo posição do ator selecionado. Clique no indicador do quadro-chave. Mova o mouse para a direita ou esquerda para alternar o quadro-chave para o quadro mais próximo ou distante. Clique novamente para soltar o indicador.

Apagar - Torna um quadro-chave um quadro normal.

Tensão - Controla a elasticidade da trilha. Mova o cursor para a direita ou esquerda da curva para ajustar. É aplicado apenas a interpolações suaves.